Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-19418

Install Gradle 6.0 in Jenkins

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: None
    • Component/s: Jenkins
    • Labels:
      None
    • Project:
      Kafka

      Description

      The most recent version installed in Jenkins is 4.10.3:

      https://cwiki.apache.org/confluence/display/INFRA/Gradle+Installations

      This is pretty old and it would be helpful to install 6.0, which is required for Java 13 support.

      Kafka's attempt to upgrade to Gradle 6.0 is currently failing due to the old Gradle version during the gradle wrapper bootstrap process:

      https://github.com/apache/kafka/pull/7677

        Attachments

          Activity

            People

            • Assignee:
              gmcdonald Gavin McDonald
              Reporter:
              ijuma Ismael Juma
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: