Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-19316

Unable to change Gradle version on Kafka Jenkins job

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Feedback Received
    • Fix Version/s: None
    • Component/s: Jenkins
    • Labels:
      None
    • Project:
      Kafka

      Description

      The Kafka Jenkins job https://builds.apache.org/job/kafka-2.2-jdk8 is configured to use an older version of Gradle (4.8.1) that is no longer installed on the Jenkins build machines. A job for a slightly newer branch (https://builds.apache.org/job/kafka-2.3-jdk8/configure) is using Gradle 4.10.3, and works properly. I and a few other AK contributors have tried to alter the 2.2 branch job configuration (https://builds.apache.org/job/kafka-2.2-jdk8/configure) to use the 4.10.3 Gradle version, but when we save/apply the job continues to use the 4.8.1 version.

      This is currently holding up an Apache Kafka release (2.2.2). Because of that, I'm marking this as a blocker -- though I'm not sure that's justified.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rhauch Randall Hauch
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: