Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-18883

Install Ruby >= 2.4 for Flink buildbot

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Waiting for user
    • Priority: Major
    • Resolution: Unresolved
    • Fix Version/s: None
    • Component/s: Buildbot
    • Labels:
      None
    • Project:
      Flink

      Description

      Hey Infra-Team!
      Is it possible to get a newer Ruby version in the buildbot environment on {{bb_slave2_ubuntu}}? We use buildbot for generating Flink docs via Jekyll and the currently installed version is 2.3.1 (see https://github.com/apache/infrastructure-puppet/blob/deployment/data/nodes/bb-slave2.apache.org.yaml)
      We want to upgrade Jekyll since the new version builds the docs much faster but that requires the newer Ruby version (>= 2.4.0). I think, installing it in addition to 2.3.1 should not be a problem and we can then switch once we are ready).

      The related Flink ticket is https://issues.apache.org/jira/browse/FLINK-13726

        Attachments

          Activity

            People

            • Assignee:
              dfoulks Drew Foulks
              Reporter:
              NicoK Nico Kruber
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: