Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: None
    • Component/s: Jenkins
    • Labels:
      None
    • Project:
      Beam

      Description

      pip version on Beam executors is 1.5.4 (3yo), and this is causing very long compile times for the Beam Python SDK. Latest version is 9.0.1; upgrading to this version would halve or more the build time for the Python SDK.

      The quick fix is `sudo pip install --upgrade pip` on each executor, but if a better solution is available through e.g. puppet that's perfect as well. :)

        Activity

        Hide
        pono Daniel Takamori added a comment -
        https://github.com/apache/infrastructure-puppet/blob/2b5c271739bf3ca709214f6d2014d75bde701ec9/modules/build_slaves/manifests/init.pp#L26

        manually ran puppet on jenkins-beam1, so just waiting for all jenkins nodes to run puppet and update.

        jenkins-beam1:~# pip --version
        pip 9.0.1 from /usr/local/lib/python2.7/dist-packages (python 2.7)
        Show
        pono Daniel Takamori added a comment - https://github.com/apache/infrastructure-puppet/blob/2b5c271739bf3ca709214f6d2014d75bde701ec9/modules/build_slaves/manifests/init.pp#L26 manually ran puppet on jenkins-beam1, so just waiting for all jenkins nodes to run puppet and update. jenkins-beam1:~# pip --version pip 9.0.1 from /usr/local/lib/python2.7/dist-packages (python 2.7)
        Hide
        gmcdonald Gavin added a comment -
        [~pono] ping.
        Show
        gmcdonald Gavin added a comment - [~pono] ping.

          People

          • Assignee:
            pono Daniel Takamori
            Reporter:
            jasonkuster Jason Kuster
            Request participants:
            None
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: