Details

    • Type: GitBox Request
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Sep 2017
    • Component/s: GitBox
    • Labels:
      None

      Activity

      danhaywood Dan Haywood added a comment - Reporter
      OK, great. Confirmed that I can now push directly to https://github.com/apache/isis . This ticket can be closed; I'll inform rest of team.
      pono Daniel Takamori added a comment -
      https://gitbox.apache.org/repos/asf?p=isis.git;a=summary

      Your team will need to link their Github and ASF ids, as well as enable 2factor on github: https://gitbox.apache.org/setup/
      danhaywood Dan Haywood added a comment - Reporter
      any reply for me on this? it's been a few... thx.
      danhaywood Dan Haywood added a comment - Reporter
      I would like to be able to merge pull requests from the github UI (eg https://github.com/apache/isis/pull/90).
      pono Daniel Takamori added a comment -
      Gitbox is for using Github as the canonical source of code. Previously to establishing Gitbox, we hosted the primary copy of repos on our servers and then mirrored to Github. This is how Isis is setup.
      Is there something you are lacking on the Gitbox side that you want?
      danhaywood Dan Haywood added a comment - Reporter
      It looks like I misread the first question... Apache Isis is mirrored on github, but it doesn't have existing gitbox repos (so far as I'm aware ... I'm not even entirely certain what that means).
      cthistle Chris Thistlethwaite added a comment -
      Congratulations! You're pre-approved to use the Self Service tool to create your repo to GitBox!

      If this is a new repo not currently in git.a.o, please visit https://gitbox.apache.org/setup/newrepo.html.

      Else, the INFRA team will have to move your existing repo to GitBox and you cannot use the self serve portal. We will get to your ticket as soon as possible.

      If there are further options or questions outside of just enabling GitBox, then just leave the ticket open and the INFRA team will address them accordingly.

        People

        • Assignee:
          pono Daniel Takamori
          Reporter:
          danhaywood Dan Haywood
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: