Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-14843

Zest => Polygene, but there are still references to Zest

    Details

    • Type: Bug
    • Status: Waiting for Infra
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: None
    • Component/s: Subversion, Website
    • Labels:
      None
    • Project:
      Infrastructure

      Description

      Zest was renamed to Polygene in Jan 2017, however there are still references to Zest:

      Website: zest.apache.org
      Should be redirected

      asf-auth: reference to zest for /zest karma
      pit-auth: reference to zest (unused)

      References to zest should be dropped; the SVN repo can possibly be deleted as well?

        Activity

        sebb@apache.org Sebb added a comment - Reporter
        bq. So, from a user standpoint, the https: will no longer be served.

        That works for me.
        gstein Greg Stein added a comment -
        The domain transfer has been initiated. Generally, Dotster will hang onto the domain for (5) days before releasing it. So we should see the transfer complete some time this weekend.
        gstein Greg Stein added a comment -
        I will begin the move of qi4j.org domain hosting from Dotster to Namecheap, then use the latter's "URL Redirect" feature to redirect qi4j to polygene. That feature does not serve/open the :443 port for the domain.

        So, from a user standpoint, the https: will no longer be served.
        sebb@apache.org Sebb added a comment - Reporter
        The problem is that https://qi4j.org/ redirects to the wrong site.

        It would be better to either reject attempts to use https: for that host, or redirect to http: if that does not involve an SSL cert.
        gmcdonald Gavin added a comment -
        This is a rare case that I do not feel the need to document, multiple renamed project that also moved from svnpubsub to gitpubsub after the last rename all contributed
        gmcdonald Gavin added a comment -
        No Sebb, did not miss that check, we discussed and agreed we would not be buying an ssl cert for qi4j.org just to make that redirect.
        sebb@apache.org Sebb added a comment - Reporter
        Missed another check:

        $ curl -I http://qi4j.org/
        HTTP/1.1 301 Moved Permanently
        Date: Tue, 15 Aug 2017 15:01:41 GMT
        Server: Apache/2.4.7 (Ubuntu)
        Location: http://polygene.apache.org/
        Content-Type: text/html; charset=iso-8859-1

        That's OK; however:

        $ curl -Ik https://qi4j.org/
        HTTP/1.1 200 OK
        Date: Tue, 15 Aug 2017 15:02:06 GMT
        Server: Apache/2.4.7 (Ubuntu)
        Accept-Ranges: bytes
        Vary: Accept-Encoding
        Content-Type: text/html

        The https URL redirects to an OOO site.
        sebb@apache.org Sebb added a comment - Reporter
        Now works.

        As a follow-up, is there some infra documentation that needs to be updated?
        gmcdonald Gavin added a comment -
        Ok Sebb, will let you check this again and close if good finally.
        sebb@apache.org Sebb added a comment - Reporter
        As it happens, I'm currently on a different computer and IP.
        https is not redirecting here either.
        sebb@apache.org Sebb added a comment - Reporter
        Frayed knot:

        {code}
        $ curl -Ik https://zest.apache.org/
        HTTP/1.1 200 OK
        Date: Sun, 13 Aug 2017 12:03:51 GMT
        Server: Apache/2.4.18 (Ubuntu)
        Last-Modified: Sat, 02 Jul 2016 14:45:30 GMT
        ETag: "34ca-536a82796b9ab"
        Accept-Ranges: bytes
        Content-Length: 13514
        Vary: Accept-Encoding
        Content-Type: text/html
        {code}

        http works fine, but https does not redirect.
        gmcdonald Gavin added a comment -
        Seems the two older servers had .htaccess redirects from their old svn site in place, whereas tlp-eu-new did not.

        I've added zest redirects to all 3 servers and it now works fine. (tested also from an eu location)
        sebb@apache.org Sebb added a comment - Reporter
        PING httpd.eu.apache.org (62.210.60.236)
        PING httpd.us.apache.org (140.211.11.105)
        PING httpd.apache.org (140.211.11.105)

        Not sure why I get the US site.
        c.f.
        PING commons.eu.apache.org (88.198.26.2)
        PING commons.us.apache.org (140.211.11.105)
        PING commons.apache.org (88.198.26.2)
        gmcdonald Gavin added a comment -
        PING zest.us.apache.org (140.211.11.105) <--- This is Themis
        PING zest.eu.apache.org (88.198.26.2) <--- tlp-eu-mid ( I thought this was taken out of rotation)
        PING zest.apache.org (62.210.60.236) <--- tlp-eu-new (This is tlp-eu-mid replacement)

        So I guess 'new' is not getting updated. I'll check further, thanks.
        sebb@apache.org Sebb added a comment - Reporter
        PING polygene.eu.apache.org (62.210.60.236)
        PING polygene.us.apache.org (140.211.11.105)
        PING polygene.apache.org (88.198.26.2)
        sebb@apache.org Sebb added a comment - Reporter
        PING zest.us.apache.org (140.211.11.105)
        PING zest.eu.apache.org (88.198.26.2)
        PING zest.apache.org (62.210.60.236)
        sebb@apache.org Sebb added a comment - Reporter
        88.198.26.2

        I do see redirects when logged into mino or hermes.
        Try the same curl when logged into a host based in Europe.
        gmcdonald Gavin added a comment -
        what IP does apache.org resolve for you?
        gmcdonald Gavin added a comment -
        curl -Ik http://zest.apache.org/
        HTTP/1.1 301 Moved Permanently
        Date: Sun, 13 Aug 2017 10:04:37 GMT
        Server: Apache/2.4.7 (Ubuntu)
        Location: https://polygene.apache.org/content/
        Content-Type: text/html; charset=iso-8859-1

        sebb@apache.org Sebb added a comment - Reporter
        There's still a problem with the website.
        The .eu/.us URLs redirect OK.
        [The protocol is unconditionally changed to https, but that is a side issue.]

        For me, the generic site does not redirect:
        {code}
        curl -I https://zest.apache.org/
        HTTP/1.1 200 OK
        Date: Sun, 13 Aug 2017 09:46:45 GMT
        Server: Apache/2.4.18 (Ubuntu)
        Last-Modified: Sat, 02 Jul 2016 14:45:30 GMT
        ETag: "34ca-536a82796b9ab"
        Accept-Ranges: bytes
        Content-Length: 13514
        Vary: Accept-Encoding
        Content-Type: text/html

        $ curl -Ik http://zest.apache.org/
        HTTP/1.1 200 OK
        Date: Sun, 13 Aug 2017 09:59:33 GMT
        Server: Apache/2.4.18 (Ubuntu)
        Last-Modified: Sat, 02 Jul 2016 14:45:30 GMT
        ETag: "34ca-536a82796b9ab"
        Accept-Ranges: bytes
        Content-Length: 13514
        Vary: Accept-Encoding
        Content-Type: text/html
        {code}

        Note the Last-Modified date.

        gmcdonald Gavin added a comment -
        PR's applied, and zest.eu.ao is also now fixed.

        Thanks.
        gmcdonald Gavin added a comment -
        [~sebb@apache.org] remember to transition issues back to WFI .
        sebb@apache.org Sebb added a comment - Reporter
        Redirection does not work for me.
        Tried reloading and several browsers.

        Seems to be a problem with the eu mirror not having the correct redirects.

        Try zest.eu.apache.org and you should see what I see.
        gmcdonald Gavin added a comment -
        I have commented on the PR - but will repeat here, I see removals of Zest auth but no additions of Polygene auth, is that what was intended.
        gmcdonald Gavin added a comment -
        I checked http[s] ://zest.apache.org it they redirect to polygene.apache.org just fine.
        sebb@apache.org Sebb added a comment - Reporter
        https://github.com/apache/infrastructure-puppet/pull/302 removes references to zest from the auth files

          People

          • Assignee:
            gstein Greg Stein
            Reporter:
            sebb@apache.org Sebb
            Request participants:
            None
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: