Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: None
    • Component/s: Jenkins
    • Labels:
      None
    • Project:
      Hadoop

      Description

      I filed INFRA-13618 earlier this week since H9 was eating our Hadoop builds. This has happened a few more times and only to H9 which indicates that this is an H9-specific problem.

      Could we get this slave reprovisioned? Gavin mentioned on INFRA-13618 this was a bit tricky.

        Activity

        Hide
        ipv6guru Gavin added a comment -
        We cant image it ourselves so I'll have to speak to Rajive and have the conversation about adding our puppet config to it at the same time.
        Show
        ipv6guru Gavin added a comment - We cant image it ourselves so I'll have to speak to Rajive and have the conversation about adding our puppet config to it at the same time.
        Hide
        ipv6guru Gavin added a comment -
        The H9 node itself doesnt look any different to H10 or other nodes.

        I have removed:-

        /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/hadoop-hdfs-project/hadoop-hdfs/target

        from H9 and H10 - permissions above that level seems fine.

        Can you give those two specific nodes a test please and let me know how you get on.?
        Show
        ipv6guru Gavin added a comment - The H9 node itself doesnt look any different to H10 or other nodes. I have removed:- /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/hadoop-hdfs-project/hadoop-hdfs/target from H9 and H10 - permissions above that level seems fine. Can you give those two specific nodes a test please and let me know how you get on.?
        Hide
        andrew.wang Andrew Wang added a comment - Reporter
        I'm going to close this issue, we did some more investigation on our own, and adding an additional chmod step to our build is the fix for now. We originally thought it was an H9 issue since it hit this multiple times in a row, but once we excluded H9, the other notes started breaking too.
        Show
        andrew.wang Andrew Wang added a comment - Reporter I'm going to close this issue, we did some more investigation on our own, and adding an additional chmod step to our build is the fix for now. We originally thought it was an H9 issue since it hit this multiple times in a row, but once we excluded H9, the other notes started breaking too.

          People

          • Assignee:
            ipv6guru Gavin
            Reporter:
            andrew.wang Andrew Wang
            Request participants:
            None
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: