Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-12629

Install missing perl-LWP-Protocol-https in bb-win7

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: Sep 2016
    • Component/s: Buildbot
    • Labels:
      None

      Description

      Build aoo-w741x on bb-win7 is failing due to a missing Perl module:

      https://ci.apache.org/builders/aoo-w741x/builds/3/steps/configure/logs/stdio
      checking for required Perl modules... configure: error:
          The missing Perl modules are: LWP::Protocol::https
          Install them with your package manager (the name of the package depends on your system);
          or, as last resort, run the following command as superuser/administrator: "cpan -i LWP::Protocol::https"

      It would be better not to follow the advice in configure, do not use cpan, instead use cygwin's setup-x86.exe as detailed here https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO#General_Build_Requirements

      The name of the package containing LWP::Protocol::https is perl-LWP-Protocol-https

        Attachments

          Activity

            People

            • Assignee:
              pono Daniel Takamori
              Reporter:
              arielch Ariel Constenla-Haile
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: