Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-9279

Update the Kudu version to include VARCHAR support (and other functionality)

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Critical
    • Resolution: Fixed
    • Impala 3.4.0
    • Impala 3.4.0
    • Infrastructure
    • None
    • ghx-label-1

    Description

      There are several commits in progress that require Impala to use a more recent version of Kudu. Since the Kudu version in CDH build number is not recent, the current method of using Kudu from the CDH build number needs to change.

      In the long term, using Kudu from the CDP build number makes sense, once that supports all the platforms needed. That is tracked by IMPALA-8943.

      However, in the short term, it makes more sense to use Kudu from the native toolchain. This would apply for both USE_CDP_HIVE=true and USE_CDP_HIVE=false. This will require the native toolchain Kudu to provide maven artifacts. That is tracked by IMPALA-9265.

      Attachments

        Issue Links

          Activity

            People

              attilaj Attila Jeges
              joemcdonnell Joe McDonnell
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: