Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-8799

Prometheus metrics should be prefixed with "impala_"

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • Impala 3.3.0
    • Backend

    Description

      This is recommended by the Prometheus docs - https://prometheus.io/docs/practices/naming/

      A metric name...

      ...must comply with the data model for valid characters.
      ...should have a (single-word) application prefix relevant to the domain the metric belongs to. The prefix is sometimes referred to as namespace by client libraries. For metrics specific to an application, the prefix is usually the application name itself. Sometimes, however, metrics are more generic, like standardized metrics exported by client libraries. Examples:
      prometheus_notifications_total (specific to the Prometheus server)
      process_cpu_seconds_total (exported by many client libraries)
      http_request_duration_seconds (for all HTTP requests)

      It is also awkward in tools like grafana to find impala metrics with the current naming scheme.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tarmstrong Tim Armstrong
            tarmstrong Tim Armstrong
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment