Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-8766

Change hadoop cloud dependencies to use hadoop-cloud-storage

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Impala 3.3.0
    • Fix Version/s: Impala 3.3.0
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      Currently, fe/pom.xml specifically includes hadoop-aws, hadoop-azure, and hadoop-azure-datalake directly. There is a meta-package in hadoop called hadoop-cloud-storage that includes these dependencies and others as customized by the hadoop provider, with appropriate exclusions applied to each package.

      Migrating Impala to use this meta-package would make it easier for different providers of hadoop to customize hadoop-cloud-storage and the resulting CLASSPATH without needing to change Impala. For example, a hadoop provider may want to include Apache Knox for cloud identity management.

        Attachments

          Activity

            People

            • Assignee:
              joemcdonnell Joe McDonnell
              Reporter:
              joemcdonnell Joe McDonnell
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: