Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-8369

Impala should be able to interoperate with Hive 3.1.0

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Currently, Impala only works with Hive 2.1.1. Since Hive 3.1.0 has been released for a while it would be good to add support for Hive 3.1.0 (HMS 3.1.0). This patch will focus on ability to connect to HMS 3.1.0 and run existing tests. It will not focus on adding support for newer features like ACID in Hive 3.1.0 which can be taken up as separate JIRA.

      It would be good to make changes to Impala source code such that it can work with both Hive 2.1.0 and Hive 3.1.0 without the need to create a separate branch. However, this should be a aspirational goal. If we hit a blocker we should investigate alternative approaches.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vihangk1 Vihang Karajgaonkar
                Reporter:
                vihangk1 Vihang Karajgaonkar
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: