Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-8332

Remove Impala Shell warnings part 1

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • Impala 3.3.0
    • None
    • ghx-label-3

    Description

      When connecting to a secure cluster, Impala-shell produces several Thrift-related warnings.
      This has been happening since “IMPALA-5690: Part 2: Upgrade thrift to 0.9.3-p4”.

      [root@nightly61x-2 ~]# impala-shell -i nightly61x-2.xxx.com:25003 -d default -k --ssl --ca_cert=/etc/xxxf/CA_STANDARD/truststore.pem
      Starting Impala Shell using Kerberos authentication
      Using service name 'impala'
      SSL is enabled
      /opt/cloudera/parcels/CDH-6.1.x-1.cdh6.1.x.p0.972267/lib/impala-shell/lib/thrift/transport/TSSLSocket.py:80: DeprecationWarning: 3th positional argument is deprecated. Use keyward argument insteand.
      DeprecationWarning)
      /opt/cloudera/parcels/CDH-6.1.x-1.cdh6.1.x.p0.972267/lib/impala-shell/lib/thrift/transport/TSSLSocket.py:80: DeprecationWarning: 4th positional argument is deprecated. Use keyward argument insteand.
      DeprecationWarning)
      /opt/cloudera/parcels/CDH-6.1.x-1.cdh6.1.x.p0.972267/lib/impala-shell/lib/thrift/transport/TSSLSocket.py:80: DeprecationWarning: 5th positional argument is deprecated. Use keyward argument insteand.
      DeprecationWarning)
      /opt/cloudera/parcels/CDH-6.1.x-1.cdh6.1.x.p0.972267/lib/impala-shell/lib/thrift/transport/TSSLSocket.py:216: DeprecationWarning: validate is deprecated. Use cert_reqs=ssl.CERT_REQUIRED instead
      DeprecationWarning)
      /opt/cloudera/parcels/CDH-6.1.x-1.cdh6.1.x.p0.972267/lib/impala-shell/lib/thrift/transport/TSSLSocket.py:227: DeprecationWarning: Use cert_reqs instead
      warnings.warn('Use cert_reqs instead', DeprecationWarning)
      Opened TCP connection tonightly61x-2.xxx.com:25003

      The first 4 of these warnings are caused by our usage of the TSSLSocket initialiser TSSLSocket._init_.
      In Thrift 0.9.3 this initialiser prints warnings if positional parameters are used.

      The 5th warning is covered by IMPALA-8333 Remove Impala Shell warnings part 2

      Attachments

        Activity

          People

            asherman Andrew Sherman
            asherman Andrew Sherman
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: