Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-6695

Builds fail with pkg_resources.VersionConflict

    Details

    • Epic Color:
      ghx-label-3

      Description

      18:25:05   InsecurePlatformWarning
      18:25:05     Complete output from command python setup.py egg_info:
      18:25:05     Using KUDU_HOME directory: /tmp/virtualenv-kudu
      18:25:05     Using inferred KUDU_BUILD directory: /tmp/virtualenv-kudu/build/latest/
      18:25:05     /usr/lib64/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option: 'python_requires'
      18:25:05       warnings.warn(msg)
      18:25:05     zip_safe flag not set; analyzing archive contents...
      18:25:05     
      18:25:05     Installed /tmp/pip-build-7nwsKF/kudu-python/.eggs/pytest_runner-4.1-py2.6.egg
      18:25:05     Traceback (most recent call last):
      18:25:05       File "<string>", line 20, in <module>
      18:25:05       File "/tmp/pip-build-7nwsKF/kudu-python/setup.py", line 172, in <module>
      18:25:05         test_suite="kudu.tests"
      18:25:05       File "/usr/lib64/python2.6/distutils/core.py", line 113, in setup
      18:25:05         _setup_distribution = dist = klass(attrs)
      18:25:05       File "/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages/setuptools/dist.py", line 268, in __init__
      18:25:05         self.fetch_build_eggs(attrs['setup_requires'])
      18:25:05       File "/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages/setuptools/dist.py", line 313, in fetch_build_eggs
      18:25:05         replace_conflicting=True,
      18:25:05       File "/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages/pkg_resources/__init__.py", line 836, in resolve
      18:25:05         dist = best[req.key] = env.best_match(req, ws, installer)
      18:25:05       File "/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages/pkg_resources/__init__.py", line 1074, in best_match
      18:25:05         dist = working_set.find(req)
      18:25:05       File "/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages/pkg_resources/__init__.py", line 711, in find
      18:25:05         raise VersionConflict(dist, req)
      18:25:05     pkg_resources.VersionConflict: (setuptools 18.0.1 (/data/jenkins/workspace/impala-cdh6.0.0_beta1-exhaustive-release/repos/Impala/infra/python/env/lib/python2.6/site-packages), Requirement.parse('setuptools>=27.3'))
      

        Attachments

          Activity

            People

            • Assignee:
              lv Lars Volker
              Reporter:
              lv Lars Volker
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: