Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-6012

HIVE-12730 breaks Impala compilation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.11.0
    • Fix Version/s: Impala 2.11.0
    • Component/s: Frontend
    • Labels:
      None

      Description

      The version of Hive that master depends on recently included HIVE-12730, which changes some APIs to match the Hive 2 versions. HIVE-17189 makes HIVE-12730 backward compatible but hasn't made it into our dependencies yet.

      This breaks the Impala build. However, since the two sets of APIs are now aligned, we can switch to using the newer APIs without a shim.

        Attachments

          Activity

            People

            • Assignee:
              tarmstrong Tim Armstrong
              Reporter:
              tarmstrong Tim Armstrong
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: