Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5886

run-tests.py returns error overeagerly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Impala 2.10.0
    • Fix Version/s: None
    • Component/s: Infrastructure
    • Labels:
    • Epic Color:
      ghx-label-2

      Description

      pytest.main returns 5 if no tests are selected. When EE tests are run but no tests of one of the categories (serial, stress, other) is run, then run-tests.py calls sys.exit(1). The exit_code in the run_tests method should check for the designated return value 5, "No tests were collected": https://docs.pytest.org/en/latest/usage.html

      repro:
      FE_TEST=false BE_TEST=false EE_TEST=true EE_TEST_FILES=query_test/test_udfs.py JDBC_TEST=false CLUSTER_TEST=false bin/run-all-tests.sh

       

      Adding some more details here

      current and expected behavior from run-tests.py with the changes

      • return 0 if EE tests pass
      • return 1 if EE tests fail
      • return 0 if no tests were collected in a scenario where no EE tests are being run
      • return 1 if no tests were collected when EE tests were expected to run but there is some error

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                njanarthanan nithya
                Reporter:
                jbapple Jim Apple
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: