Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5075

query_test.test_queries.TestQueriesTextTables.test_strict_mode fails on SLES12 SP2

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: None
    • Labels:
      None
    • Epic Color:
      ghx-label-9

      Description

      This runs successfully on Ubuntu, Centos, Redhat, Debian, and Oracle. However, it fails on SLES12 with the following error:

      Stacktrace:

      query_test/test_queries.py:150: in test_strict_mode
          self.run_test_case('QueryTest/strict-mode', vector)
      common/impala_test_suite.py:388: in run_test_case
          self.__verify_results_and_errors(vector, test_section, result, use_db)
      common/impala_test_suite.py:273: in __verify_results_and_errors
          replace_filenames_with_placeholder)
      common/test_result_verifier.py:317: in verify_raw_results
          verify_errors(expected_errors, actual_errors)
      common/test_result_verifier.py:274: in verify_errors
          VERIFIER_MAP['VERIFY_IS_EQUAL'](expected, actual)
      common/test_result_verifier.py:231: in verify_query_result_is_equal
          assert expected_results == actual_results
      E   assert Comparing QueryTestResults (expected vs actual):
      E     'Error converting column: 0 to TINYINT' == 'Error converting column: 0 to TINYINT'
      E     'Error converting column: 0 to TINYINT' == 'Error converting column: 0 to TINYINT'
      E     'Error converting column: 1 to SMALLINT' == 'Error converting column: 1 to SMALLINT'
      E     'Error converting column: 1 to SMALLINT' == 'Error converting column: 1 to SMALLINT'
      E     'Error converting column: 2 to INT' == 'Error converting column: 2 to INT'
      E     'Error converting column: 2 to INT' == 'Error converting column: 2 to INT'
      E     'Error converting column: 3 to BIGINT' == 'Error converting column: 3 to BIGINT'
      E     'Error converting column: 3 to BIGINT' == 'Error converting column: 3 to BIGINT'
      E     'Error converting column: 4 to FLOAT' == 'Error converting column: 4 to FLOAT'
      E     'Error converting column: 4 to FLOAT' == 'Error converting column: 4 to FLOAT'
      E     'Error converting column: 5 to DOUBLE' == 'Error converting column: 5 to DOUBLE'
      E     'Error converting column: 5 to DOUBLE' == 'Error converting column: 5 to DOUBLE'
      E     'Error converting column: 6 to DECIMAL(13,4)' != 'Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/test-warehouse/overflow/overflow.txt, before offset: 160'
      E     'Error converting column: 6 to DECIMAL(13,4)' != 'Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/test-warehouse/overflow/overflow.txt, before offset: 160'
      E     'Error converting column: 7 to DECIMAL(38,0)' != None
      E     'Error converting column: 7 to DECIMAL(38,0)' != None
      E     'Error converting column: 8 to DECIMAL(38,38)' != None
      E     'Error converting column: 8 to DECIMAL(38,38)' != None
      E     row_regex: .*Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/.* before offset: \d+ != None
      E     row_regex: .*Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/.* before offset: \d+ != None
      E     Number of rows returned (expected vs actual): 20 != 14
      

        Activity

        dknupp David Knupp added a comment -

        Query that failed:

        use functional;
        
        SET strict_mode=1;
        SET batch_size=0;
        SET num_nodes=0;
        SET disable_codegen=False;
        SET abort_on_error=0;
        SET exec_single_node_rows_threshold=0;
        -- executing against <impalad_host>:21000
        select * from overflow;
        
        MainThread: Comparing QueryTestResults (expected vs actual):
        'Error converting column: 0 to TINYINT' == 'Error converting column: 0 to TINYINT'
        'Error converting column: 0 to TINYINT' == 'Error converting column: 0 to TINYINT'
        'Error converting column: 1 to SMALLINT' == 'Error converting column: 1 to SMALLINT'
        'Error converting column: 1 to SMALLINT' == 'Error converting column: 1 to SMALLINT'
        'Error converting column: 2 to INT' == 'Error converting column: 2 to INT'
        'Error converting column: 2 to INT' == 'Error converting column: 2 to INT'
        'Error converting column: 3 to BIGINT' == 'Error converting column: 3 to BIGINT'
        'Error converting column: 3 to BIGINT' == 'Error converting column: 3 to BIGINT'
        'Error converting column: 4 to FLOAT' == 'Error converting column: 4 to FLOAT'
        'Error converting column: 4 to FLOAT' == 'Error converting column: 4 to FLOAT'
        'Error converting column: 5 to DOUBLE' == 'Error converting column: 5 to DOUBLE'
        'Error converting column: 5 to DOUBLE' == 'Error converting column: 5 to DOUBLE'
        'Error converting column: 6 to DECIMAL(13,4)' != 'Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/test-warehouse/overflow/overflow.txt, before offset: 160'
        'Error converting column: 6 to DECIMAL(13,4)' != 'Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/test-warehouse/overflow/overflow.txt, before offset: 160'
        'Error converting column: 7 to DECIMAL(38,0)' != None
        'Error converting column: 7 to DECIMAL(38,0)' != None
        'Error converting column: 8 to DECIMAL(38,38)' != None
        'Error converting column: 8 to DECIMAL(38,38)' != None
        row_regex: .*Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/.* before offset: \d+ != None
        row_regex: .*Error parsing row: file: hdfs://impala-sles12sp2-test-cluster-1.vpc.cloudera.com:8020/.* before offset: \d+ != None
        Number of rows returned (expected vs actual): 20 != 14
        
        dknupp David Knupp added a comment -

        It's possible this was caused by incorrect test data. The data in the test warehouse was updated, and the tests passed. I will resolve this for now, but will still keep an eye on future tests on this build.


          People

          • Assignee:
            Unassigned
            Reporter:
            dknupp David Knupp
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development