Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-3883

Impalad services did not start correctly and exiting due to failed to (re-)register Resource Broker with Llama

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: Impala 2.5.0
    • Fix Version/s: None
    • Component/s: Backend
    • Labels:
    • Environment:
      Red Hat Enterprise Linux Server release 6.5

      Description

      I have installed Impala with Llama HA in my environment
      . When I sequentially start Llama HA and Impala,Llama HA start successfully
      ,but Impalad services did not start correctly and exiting due to failed to (re-)register Resource Broker with Llama.
      After checking log files of Llama and Impalad service, I find the reason is that llama_registration_timeout_secs of Impalad, which means maximum number of seconds that Impala will attempt to (re-)register with Llama before aborting the triggering action with an error, 30 seconds is less than Llama election time-consuming which is more than one minute. So Impalad can't register with any Llama and exit before Llama become active.
      We should enlarge llama_registration_timeout_secs of Impalad to 300 seconds or other value big enough to insure Impalad service starting correctly.

        Attachments

        1. impala-mr-impala-zdh227.log.ERROR.20160720-102200.17360
          0.8 kB
          Donghui Xu
        2. impala-mr-llama-zdh224.log
          22 kB
          Donghui Xu
        3. impala-mr-llama-zdh227.log
          21 kB
          Donghui Xu

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              davidxdh Donghui Xu
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: