Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-3852

Remove a couple of unnecessary FE dependencies

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Impala 2.7.0
    • Fix Version/s: Impala 2.7.0
    • Component/s: Frontend
    • Labels:
      None

      Description

      Our FE pom.xml includes a couple of dependencies that I don't think are needed, and that are pinned to specific versions that might be susceptible to vulnerabilities now or in the future:

           <dependency>
            <groupId>org.apache.shiro</groupId>
            <artifactId>shiro-core</artifactId>
            <version>1.2.1</version>
          </dependency>
      
           <dependency>
            <groupId>org.apache.derby</groupId>
            <artifactId>derby</artifactId>
            <version>10.4.2.0</version>
          </dependency>
      

        Attachments

          Activity

            People

            • Assignee:
              henryr Henry Robinson
              Reporter:
              henryr Henry Robinson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: