Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-10544

Use Centos 7.4 or above for native toolchain

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • Impala 4.0.0
    • Impala 4.0.0
    • Infrastructure
    • None
    • ghx-label-8

    Description

      Centos 7 started using OpenSSL 1.0.2 in version 7.4. There are some packages that now require OpenSSL 1.0.2 or above (jwt-cpp).

      Native toolchain currently uses a docker image built on Centos 7.2, which has OpenSSL 1.0.1. This should move to some version of Centos that uses OpenSSL 1.0.2.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            joemcdonnell Joe McDonnell
            joemcdonnell Joe McDonnell
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment