Uploaded image for project: 'Ignite'
  1. Ignite
  2. IGNITE-8441

Java 9/10/11 Support [2.5-2.7]

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Enhance Ignite Tests 2.4+ (Java 8) project with ability to run build and tests under JDK9. Fix all incoming problems so that full Run All test runs on same branches provide similar results (excluding flaky tests).

      Some known problems:

      • some current versions of used maven plugins and 3rd party dependencies are still not ready for Java 9
      • some JVM options of current test build configurations require revision
      • scala – both 2.10 and 2.11 currently used in building and testing do not support Java 9

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vveider Peter Ivanov
                Reporter:
                vveider Peter Ivanov
              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m