Uploaded image for project: 'Ignite'
  1. Ignite
  2. IGNITE-3155

visorcmd: connection to the grid with default config doesn't work

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: visor
    • Labels:
      None
    • Environment:

      Ubuntu 14.04, Apache Ignite 1.6.0

      Description

      ---------------------------------------------
      DESCRIPTION
      ---------------------------------------------
      When user try to connect to the grid with default config by command "open -d" nothing happens
      ---------------------------------------------
      STEPS FOR REPRODUCE
      ---------------------------------------------

      1. Run node from IGNITE_HOME with default config (./config/default-config.xml) by command "./bin/ignite.sh -v"
      2. Run ignitevisorcmd.sh
      3. Connect visor to the grid by the command "open -d"
      4. Type "node"
        ---------------------------------------------
        ACTUAL RESULT
        ---------------------------------------------
      5. Topology is empty
        ---------------------------------------------
        EXPECTED RESULT
        ---------------------------------------------
      6. Message "Detailed statistics (y/n) [n]:" is presented
        ---------------------------------------------
        ADDITIONAL INFO
        ---------------------------------------------
      7. Reproducible if visorcmd is started before node
      8. If the next step for presented scenario will be run node by command
        ./bin/ignite.sh -v ./examples/config/example-ignite.xml
        

        Then topology will not be empty yet. But if scenario is:

        • run node by command "./bin/ignite.sh -v ./examples/config/example-ignite.xml"
        • run ignitevisorcmd.sh
        • connect to the grid by the command "open -d"
        • type "node"
          the result will be the same - topology is empty.
      9. It's reproducible if user choose default config (0) through "open" command interactive menu

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              vsidorova Vasilisa Sidorova
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: