Uploaded image for project: 'Ignite'
  1. Ignite
  2. IGNITE-11690

.NET: Unable to locate external assembly with enabled peerAssemblyLoading

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 2.8
    • Component/s: clients
    • Labels:
    • Ignite Flags:
      Docs Required

      Description

      Original reproducer: https://www.dropbox.com/s/xsgqhwjyctyg3o3/Example%20solution.rar?dl=0 With two server nodes, and a client that spawn a computation with a simple cache iteration for custom class value

      Problem:

      If peer assembly loading enabled and no assembly exist for the nodes, then there is an endless loop: nodes are requesting the assembly from each other and no one is able to locate it.

      As an example of missing dll there could be a "System.Configuration.Configuration" for the .NET Core app https://github.com/dotnet/standard/issues/506

       

       

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ashapkin Alexandr Shapkin
                Reporter:
                ashapkin Alexandr Shapkin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 40m
                  40m