There are some bad method name about HoodieTableMetaClient, e.g.
（1） HoodieTestUtils#initTableType: it returns an instance of HoodieTableMetaClient, not about initializing table type, while it has a side effort: it initializes the path as hoodie dataset.
（2）HoodieTableMetaClient.initializePathAsHoodieDataset it also returns an instance of HoodieTableMetaClient, however, from its name, it seems we want to initialize path?
I would like to suggest rename:
(1) HoodieTestUtils#initTableType to HoodieTestUtils#init as a override method like others;
(2) HoodieTableMetaClient.initializePathAsHoodieDataset to HoodieTableMetaClient.initializeMetaClientWithPathAsHoodieDataset