Uploaded image for project: 'Apache Hudi'
  1. Apache Hudi
  2. HUDI-203 Improve Unit Test Quality in Hudi
  3. HUDI-267

Refactor bad method name HoodieTestUtils#initTableType and HoodieTableMetaClient#initializePathAsHoodieDataset

Attach filesAttach ScreenshotVotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    Description

      There are some bad method name about HoodieTableMetaClient, e.g.
      (1) HoodieTestUtils#initTableType: it returns an instance of HoodieTableMetaClient, not about initializing table type, while it has a side effort: it initializes the path as hoodie dataset.
      (2)HoodieTableMetaClient.initializePathAsHoodieDataset it also returns an instance of HoodieTableMetaClient, however, from its name, it seems we want to initialize path?

      I would like to suggest rename:
      (1) HoodieTestUtils#initTableType to HoodieTestUtils#init as a override method like others;
      (2) HoodieTableMetaClient.initializePathAsHoodieDataset to HoodieTableMetaClient.initializeMetaClientWithPathAsHoodieDataset

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            yanghua vinoyang
            yanghua vinoyang
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 20m
                20m

                Slack

                  Issue deployment