Uploaded image for project: 'Apache Hudi'
  1. Apache Hudi
  2. HUDI-2669

Upgrade Java toolset/runtime to JDK11

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Open
    • Blocker
    • Resolution: Unresolved
    • None
    • 1.0.0
    • performance

    Description

      We should upgrade to at least JDK11, or preferably current latest LTS JDK17

       

      Plan for migration:

      Compilation

      JDK8 will still be used to compile source code (both source/target will stay `1.8`): this is required to make sure as we migrate to JDK11, we don't add dependencies on features not compatible w/ JDK8. Migrating off JDK8 in toolset, will happen at a later point, when we would stop providing any assurances about the code being able to be run on 1.8.

      Runtime

      JDK11 will be used to run the code: due to JVM b/w compatibility there should be no issues of running the code compiled for 1.8 on JDK11+, other than dependencies compatibility. For that we would make sure that all our test-suites do run against JDK11+.

       

       

       

      Attachments

        Issue Links

          Activity

            People

              alexey.kudinkin Alexey Kudinkin
              shivnarayan sivabalan narayanan
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated: