Hive
  1. Hive
  2. HIVE-7770

Undo backward-incompatible behaviour change introduced by HIVE-7341

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.14.0
    • Fix Version/s: 0.14.0
    • Component/s: HCatalog
    • Labels:

      Description

      HIVE-7341 introduced a backward-incompatibility regression in Exception signatures for HCatPartition.getColumns() that breaks compilation for external tools like Falcon. This bug tracks a scrub of any other issues we discover, so we can put them back to how it used to be. This bug needs resolution in the same release as HIVE-7341, and thus, must be resolved in 0.14.0.

      1. HIVE-7770.1.patch
        2 kB
        Mithun Radhakrishnan

        Issue Links

          Activity

          Mithun Radhakrishnan added a comment -

          Yikes, will post a patch shortly.

          Mithun Radhakrishnan added a comment -

          Changed HCatPartition to pre-cache this.sd.getCols() into a member variable. Slightly redundant, but it gets around having to change the exception signature of HCatPartition.getColumns(). And it amortizes the construction-cost for multiple calls. #silverlining

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12663168/HIVE-7770.1.patch

          ERROR: -1 due to 2 failed/errored test(s), 6098 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_parquet_join
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/423/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/423/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-423/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 2 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12663168

          Sushanth Sowmyan added a comment -

          +1

          I've gone over the previous patch again and verified that this should be the only backward incompatible change we made, and this puts it back correctly. Failing tests reported by the qa bot are not related to this change. Will go ahead and commit.

          Sushanth Sowmyan added a comment -

          Committed to trunk, restores Exception-signature for the getColumns(). Thanks, Mithun!

          Thejas M Nair added a comment -

          This has been fixed in 0.14 release. Please open new jira if you see any issues.


            People

            • Assignee:
              Mithun Radhakrishnan
              Reporter:
              Sushanth Sowmyan
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development