Hive
  1. Hive
  2. HIVE-7733

Ambiguous column reference error on query

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.13.0
    • Fix Version/s: 0.14.0
    • Component/s: None
    • Labels:
      None

      Description

      CREATE TABLE agg1 
        ( 
           col0 INT, 
           col1 STRING, 
           col2 DOUBLE 
        ); 
      
      explain SELECT single_use_subq11.a1 AS a1, 
             single_use_subq11.a2 AS a2 
      FROM   (SELECT Sum(agg1.col2) AS a1 
              FROM   agg1 
              GROUP  BY agg1.col0) single_use_subq12 
             JOIN (SELECT alias.a2 AS a0, 
                          alias.a1 AS a1, 
                          alias.a1 AS a2 
                   FROM   (SELECT agg1.col1 AS a0, 
                                  '42'      AS a1, 
                                  agg1.col0 AS a2 
                           FROM   agg1 
                           UNION ALL 
                           SELECT agg1.col1 AS a0, 
                                  '41'      AS a1, 
                                  agg1.col0 AS a2 
                           FROM   agg1) alias 
                   GROUP  BY alias.a2, 
                             alias.a1) single_use_subq11 
               ON ( single_use_subq11.a0 = single_use_subq11.a0 );
      

      Gets the following error:
      FAILED: SemanticException [Error 10007]: Ambiguous column reference a2
      Looks like this query had been working in 0.12 but starting failing with this error in 0.13

      1. HIVE-7733.1.patch.txt
        1 kB
        Navis
      2. HIVE-7733.2.patch.txt
        16 kB
        Navis
      3. HIVE-7733.3.patch.txt
        21 kB
        Navis
      4. HIVE-7733.4.patch.txt
        24 kB
        Navis
      5. HIVE-7733.5.patch.txt
        34 kB
        Navis
      6. HIVE-7733.6.patch.txt
        37 kB
        Navis
      7. HIVE-7733.7.patch.txt
        37 kB
        Navis

        Issue Links

          Activity

          Yongzhi Chen added a comment -

          Navis, I just create a new jira related to the issue, do you want to look at it?
          HIVE-9528

          Thejas M Nair added a comment -

          This has been fixed in 0.14 release. Please open new jira if you see any issues.

          Ashutosh Chauhan added a comment -

          Committed to 0.14

          Vikram Dixit K added a comment -

          +1 for 0.14

          Ashutosh Chauhan added a comment -

          Committed to trunk. Thanks, Navis!
          Vikram Dixit K It will be good to have this in 0.14

          Ashutosh Chauhan added a comment -

          +1

          Navis added a comment -

          Cannot reproduce fail of TestStreaming.testTransactionBatchAbort and other fails are booked on https://issues.apache.org/jira/browse/HIVE-8465

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12674705/HIVE-7733.7.patch.txt

          ERROR: -1 due to 4 failed/errored test(s), 6557 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_parallel
          org.apache.hive.beeline.TestSchemaTool.testSchemaInit
          org.apache.hive.beeline.TestSchemaTool.testSchemaUpgrade
          org.apache.hive.hcatalog.streaming.TestStreaming.testTransactionBatchAbort
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1271/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1271/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1271/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 4 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12674705

          Navis added a comment -

          Was my bad. Updated rb link.

          Navis added a comment -

          Strange.. Cannot update patch for RB. I'll retry later.

          Ashutosh Chauhan added a comment -

          Navis Can you resubmit patch for Hive QA? Also, can you please also update RB ?

          Hive QA added a comment -

          Overall: -1 no tests executed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12673292/HIVE-7733.6.patch.txt

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1156/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1156/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1156/

          Messages:

          **** This message was trimmed, see log for full details ****
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN LPAREN KW_CASE" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_NOT KW_FALSE" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_DATE StringLiteral" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_NOT KW_TRUE" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_NOT KW_MAP" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_CASE KW_MAP" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN LPAREN KW_MAP" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_CASE KW_UNIONTYPE" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_CASE KW_STRUCT" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_NOT KW_IF" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN KW_CASE KW_IF" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:68:4: 
          Decision can match input such as "LPAREN LPAREN KW_IF" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:115:5: 
          Decision can match input such as "KW_CLUSTER KW_BY LPAREN" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:127:5: 
          Decision can match input such as "KW_PARTITION KW_BY LPAREN" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:138:5: 
          Decision can match input such as "KW_DISTRIBUTE KW_BY LPAREN" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:149:5: 
          Decision can match input such as "KW_SORT KW_BY LPAREN" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:166:7: 
          Decision can match input such as "STAR" using multiple alternatives: 1, 2
          
          As a result, alternative(s) 2 were disabled for that input
          warning(200): IdentifiersParser.g:179:5: 
          Decision can match input such as "KW_STRUCT" using multiple alternatives: 4, 6
          
          As a result, alternative(s) 6 were disabled for that input
          warning(200): IdentifiersParser.g:179:5: 
          Decision can match input such as "KW_ARRAY" using multiple alternatives: 2, 6
          
          As a result, alternative(s) 6 were disabled for that input
          warning(200): IdentifiersParser.g:179:5: 
          Decision can match input such as "KW_UNIONTYPE" using multiple alternatives: 5, 6
          
          As a result, alternative(s) 6 were disabled for that input
          warning(200): IdentifiersParser.g:261:5: 
          Decision can match input such as "KW_TRUE" using multiple alternatives: 3, 8
          
          As a result, alternative(s) 8 were disabled for that input
          warning(200): IdentifiersParser.g:261:5: 
          Decision can match input such as "KW_NULL" using multiple alternatives: 1, 8
          
          As a result, alternative(s) 8 were disabled for that input
          warning(200): IdentifiersParser.g:261:5: 
          Decision can match input such as "KW_FALSE" using multiple alternatives: 3, 8
          
          As a result, alternative(s) 8 were disabled for that input
          warning(200): IdentifiersParser.g:261:5: 
          Decision can match input such as "KW_DATE StringLiteral" using multiple alternatives: 2, 3
          
          As a result, alternative(s) 3 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "KW_BETWEEN KW_MAP LPAREN" using multiple alternatives: 8, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_INSERT KW_INTO" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_UNION KW_ALL" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_SORT KW_BY" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_CLUSTER KW_BY" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_LATERAL KW_VIEW" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_MAP LPAREN" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_DISTRIBUTE KW_BY" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_ORDER KW_BY" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_GROUP KW_BY" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:393:5: 
          Decision can match input such as "{KW_LIKE, KW_REGEXP, KW_RLIKE} KW_INSERT KW_OVERWRITE" using multiple alternatives: 2, 9
          
          As a result, alternative(s) 9 were disabled for that input
          warning(200): IdentifiersParser.g:518:5: 
          Decision can match input such as "{AMPERSAND..BITWISEXOR, DIV..DIVIDE, EQUAL..EQUAL_NS, GREATERTHAN..GREATERTHANOREQUALTO, KW_AND, KW_ARRAY, KW_BETWEEN..KW_BOOLEAN, KW_CASE, KW_DOUBLE, KW_FLOAT, KW_IF, KW_IN, KW_INT, KW_LIKE, KW_MAP, KW_NOT, KW_OR, KW_REGEXP, KW_RLIKE, KW_SMALLINT, KW_STRING..KW_STRUCT, KW_TINYINT, KW_UNIONTYPE, KW_WHEN, LESSTHAN..LESSTHANOREQUALTO, MINUS..NOTEQUAL, PLUS, STAR, TILDE}" using multiple alternatives: 1, 3
          
          As a result, alternative(s) 3 were disabled for that input
          [INFO] 
          [INFO] --- maven-remote-resources-plugin:1.5:process (default) @ hive-exec ---
          Downloading: http://www.datanucleus.org/downloads/maven2/net/hydromatic/linq4j/0.4/linq4j-0.4.pom
          [INFO] ------------------------------------------------------------------------
          [INFO] Reactor Summary:
          [INFO] 
          [INFO] Hive .............................................. SUCCESS [12.662s]
          [INFO] Hive Shims Common ................................. SUCCESS [6.608s]
          [INFO] Hive Shims 0.20 ................................... SUCCESS [3.931s]
          [INFO] Hive Shims Secure Common .......................... SUCCESS [4.900s]
          [INFO] Hive Shims 0.20S .................................. SUCCESS [2.310s]
          [INFO] Hive Shims 0.23 ................................... SUCCESS [7.085s]
          [INFO] Hive Shims ........................................ SUCCESS [1.259s]
          [INFO] Hive Common ....................................... SUCCESS [9.206s]
          [INFO] Hive Serde ........................................ SUCCESS [17.817s]
          [INFO] Hive Metastore .................................... SUCCESS [37.414s]
          [INFO] Hive Ant Utilities ................................ SUCCESS [1.734s]
          [INFO] Hive Query Language ............................... FAILURE [31.359s]
          [INFO] Hive Service ...................................... SKIPPED
          [INFO] Hive Accumulo Handler ............................. SKIPPED
          [INFO] Hive JDBC ......................................... SKIPPED
          [INFO] Hive Beeline ...................................... SKIPPED
          [INFO] Hive CLI .......................................... SKIPPED
          [INFO] Hive Contrib ...................................... SKIPPED
          [INFO] Hive HBase Handler ................................ SKIPPED
          [INFO] Hive HCatalog ..................................... SKIPPED
          [INFO] Hive HCatalog Core ................................ SKIPPED
          [INFO] Hive HCatalog Pig Adapter ......................... SKIPPED
          [INFO] Hive HCatalog Server Extensions ................... SKIPPED
          [INFO] Hive HCatalog Webhcat Java Client ................. SKIPPED
          [INFO] Hive HCatalog Webhcat ............................. SKIPPED
          [INFO] Hive HCatalog Streaming ........................... SKIPPED
          [INFO] Hive HWI .......................................... SKIPPED
          [INFO] Hive ODBC ......................................... SKIPPED
          [INFO] Hive Shims Aggregator ............................. SKIPPED
          [INFO] Hive TestUtils .................................... SKIPPED
          [INFO] Hive Packaging .................................... SKIPPED
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 2:18.928s
          [INFO] Finished at: Wed Oct 08 13:00:21 EDT 2014
          [INFO] Final Memory: 79M/449M
          [INFO] ------------------------------------------------------------------------
          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-remote-resources-plugin:1.5:process (default) on project hive-exec: Error resolving project artifact: Could not transfer artifact net.hydromatic:linq4j:pom:0.4 from/to datanucleus (http://www.datanucleus.org/downloads/maven2): Access denied to: http://www.datanucleus.org/downloads/maven2/net/hydromatic/linq4j/0.4/linq4j-0.4.pom, ReasonPhrase: Forbidden. for project net.hydromatic:linq4j:jar:0.4 -> [Help 1]
          [ERROR] 
          [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
          [ERROR] Re-run Maven using the -X switch to enable full debug logging.
          [ERROR] 
          [ERROR] For more information about the errors and possible solutions, please read the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
          [ERROR] 
          [ERROR] After correcting the problems, you can resume the build with the command
          [ERROR]   mvn <goals> -rf :hive-exec
          + exit 1
          '
          

          This message is automatically generated.

          ATTACHMENT ID: 12673292

          Navis added a comment -

          Fixed test fails

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12673054/HIVE-7733.5.patch.txt

          ERROR: -1 due to 54 failed/errored test(s), 6526 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_part
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_cbo_correctness
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_cluster
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_create_or_replace_view
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_create_view
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_create_view_partitioned
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_cte_2
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_describe_formatted_view_partitioned
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_describe_formatted_view_partitioned_json
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_join_view
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_field_garbage
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_join5
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_repeated_alias
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_udf_col
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_union
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_union_view
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subq_where_serialization
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_exists
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_exists_explain_rewrite
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_exists_having
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_in
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_in_explain_rewrite
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_in_having
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_multiinsert
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_notexists
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_notexists_having
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_notin
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_notin_having
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_unqualcolumnrefs
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_subquery_views
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_temp_table_subquery1
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_udf_compare_java_string
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_udf_to_unix_timestamp
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_union_top_level
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_vector_mapjoin_reduce
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_view_inputs
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_windowing_streaming
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynamic_partition_pruning
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_subquery_exists
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_subquery_in
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_vector_mapjoin_reduce
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_vectorized_dynamic_partition_pruning
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_ql_rewrite_gbtoidx
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_alter_view_as_select_with_partition
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_alter_view_failure6
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col0
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col1
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col2
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_create_or_replace_view1
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_create_or_replace_view2
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_create_or_replace_view7
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_invalid_select_column_with_subquery
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_invalidate_view1
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_recursive_view
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1130/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1130/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1130/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 54 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12673054

          Navis added a comment -

          Ashutosh Chauhan I've though on this again and inclined to escape uniqueness assumption on top-level select star query. Keeping backward-compatibility would be worthy if it's possible with reasonable amount of work not hurting anything (I might just hate to listen complain that a query is not working after version-up, etc.).

          Ashutosh Chauhan added a comment -

          I agree. ambiguous_col.q should fail under uniqueness assumption, which I think is a valid assumption to have. I also tested queries listed in that test case on mysql and they failed with error "ambiguous column" Also, given that changes introduced in HIVE-2723 where this test case was added was not consistent with Hive itself (HIVE-3882), I think we should not allow such ambiguity in queries. Lets move ambiguous_col.q test case to negative tests.
          Navis Would you like to rebase this patch. Lets get this one in.

          Navis added a comment - - edited

          Ashutosh Chauhan The uniqueness of columns name should be mandatory for sub query. testCliDriver_ambiguous_col should be failed under this assumption but it's succeeded in exceptional way (select-star in top-level query). Should we allow this?

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12668234/HIVE-7733.4.patch.txt

          ERROR: -1 due to 4 failed/errored test(s), 6198 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ambiguous_col
          org.apache.hadoop.hive.ql.txn.compactor.TestCompactor.testStatsAfterCompactionPartTbl
          org.apache.hive.hcatalog.pig.TestOrcHCatLoader.testReadDataPrimitiveTypes
          org.apache.hive.service.TestHS2ImpersonationWithRemoteMS.testImpersonation
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/755/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/755/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-755/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 4 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12668234

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12667972/HIVE-7733.3.patch.txt

          ERROR: -1 due to 6 failed/errored test(s), 6196 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ambiguous_col
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col0
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col1
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col2
          org.apache.hive.hcatalog.pig.TestHCatLoader.testReadDataPrimitiveTypes
          org.apache.hive.service.TestHS2ImpersonationWithRemoteMS.testImpersonation
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/744/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/744/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-744/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 6 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12667972

          Ashutosh Chauhan added a comment -

          Left a question on RB, but I didnt follow existing code either. Navis can you take a look?

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12664339/HIVE-7733.2.patch.txt

          ERROR: -1 due to 2 failed/errored test(s), 6116 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          org.apache.hive.jdbc.miniHS2.TestHiveServer2.testConnection
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/497/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/497/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-497/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 2 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12664339

          Navis added a comment -

          Second shot

          Navis added a comment -

          Looks like regression from HIVE-3107.

          Navis added a comment -

          Just a blind shot. I'll look into this.

          Jason Dere added a comment -

          Looks like this patch would break ambiguous_col.q

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12662715/HIVE-7733.1.patch.txt

          ERROR: -1 due to 3 failed/errored test(s), 5819 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ambiguous_col
          org.apache.hive.hcatalog.pig.TestOrcHCatLoader.testReadDataPrimitiveTypes
          org.apache.hive.jdbc.miniHS2.TestHiveServer2.testConnection
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/400/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/400/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-400/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 3 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12662715


            People

            • Assignee:
              Navis
              Reporter:
              Jason Dere
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development