Hive
  1. Hive
  2. HIVE-7353

HiveServer2 using embedded MetaStore leaks JDOPersistanceManager

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.13.0
    • Fix Version/s: 0.14.0
    • Component/s: HiveServer2
    • Labels:
      None

      Description

      While using embedded metastore, while creating background threads to run async operations, HiveServer2 ends up creating new instances of JDOPersistanceManager which are cached in JDOPersistanceManagerFactory. Even when the background thread is killed by the thread pool manager, the JDOPersistanceManager are never GCed because they are cached by JDOPersistanceManagerFactory.

      1. HIVE-7353.9.patch
        29 kB
        Vaibhav Gumashta
      2. HIVE-7353.8.patch
        29 kB
        Vaibhav Gumashta
      3. HIVE-7353.7.patch
        119 kB
        Vaibhav Gumashta
      4. HIVE-7353.6.patch
        113 kB
        Vaibhav Gumashta
      5. HIVE-7353.5.patch
        110 kB
        Vaibhav Gumashta
      6. HIVE-7353.4.patch
        110 kB
        Vaibhav Gumashta
      7. HIVE-7353.3.patch
        110 kB
        Vaibhav Gumashta
      8. HIVE-7353.2.patch
        106 kB
        Vaibhav Gumashta
      9. HIVE-7353.1.patch
        5 kB
        Vaibhav Gumashta

        Issue Links

          Activity

          Vaibhav Gumashta added a comment -

          Benjamin Bowman Thanks for working with me on this bug. I've attached the patch for review.

          cc Thejas M Nair

          Szehon Ho added a comment -

          Looks like a bad leak we should fix.

          I put some comment and question on the rb, thanks.

          Vaibhav Gumashta added a comment -

          Thanks for the review comments. I've taken a different approach now and the problem seems more generic. Here's the core issue:
          RawStore is kept as a threadlocal variable. A RawStore object has a reference to the JDOPersistanceManager object which JDOPersistanceManagerFactory caches. To remove the JDOPersistanceManager from the cache, an explicit JDOPersistanceManager#close call is required.
          The issue is, that in HiveServer2, we keep 2 threadpools (handler - binary mode/http mode & async) managed by an ExecutorService. Based on the config, the threadpools keep a certain number of threads live and kill excess threads after a configurable keepAliveTime expires. However, ExecutorService does not provide a hook to plug in custom cleanup code when a thread is killed - ideally this is where we'd plug in code to close the JDOPersistanceManager stored in the threadlocal RawStore.

          The current approach I've taken provides a custom ThreadFactory while creating the threadpool, which has a finalize method that does the cleanup. The ThreadFactory also maintains a map of RawStore object per Thread and in the finalize method of each thread, retrieves the RawStore object from the map, and performs the shutdown.

          On another note, remote metastore also uses ExecutorService for maintaining its ThreadPool. I haven't tested there, but similar problem should exist in that case.

          Szehon Ho added a comment -

          Yea assuming that the GC runs finalize() on the thread, this looks like a more workable solution. Left some minor comments on RB. Thanks.

          Vaibhav Gumashta added a comment -

          Addressing Lefty Leverenz's and Szehon Ho's review comments.

          Hive QA added a comment -

          Overall: -1 no tests executed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12661199/HIVE-7353.3.patch

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/275/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/275/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-275/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Tests exited with: NonZeroExitCodeException
          Command 'bash /data/hive-ptest/working/scratch/source-prep.sh' failed with exit status 1 and output '+ [[ -n /usr/java/jdk1.7.0_45-cloudera ]]
          + export JAVA_HOME=/usr/java/jdk1.7.0_45-cloudera
          + JAVA_HOME=/usr/java/jdk1.7.0_45-cloudera
          + export PATH=/usr/java/jdk1.7.0_45-cloudera/bin/:/usr/java/jdk1.6.0_34/bin:/usr/local/apache-maven-3.0.5/bin:/usr/local/apache-maven-3.0.5/bin:/usr/java/jdk1.6.0_34/bin:/usr/local/apache-ant-1.9.1/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/hiveptest/bin
          + PATH=/usr/java/jdk1.7.0_45-cloudera/bin/:/usr/java/jdk1.6.0_34/bin:/usr/local/apache-maven-3.0.5/bin:/usr/local/apache-maven-3.0.5/bin:/usr/java/jdk1.6.0_34/bin:/usr/local/apache-ant-1.9.1/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/hiveptest/bin
          + export 'ANT_OPTS=-Xmx1g -XX:MaxPermSize=256m '
          + ANT_OPTS='-Xmx1g -XX:MaxPermSize=256m '
          + export 'M2_OPTS=-Xmx1g -XX:MaxPermSize=256m -Dhttp.proxyHost=localhost -Dhttp.proxyPort=3128'
          + M2_OPTS='-Xmx1g -XX:MaxPermSize=256m -Dhttp.proxyHost=localhost -Dhttp.proxyPort=3128'
          + cd /data/hive-ptest/working/
          + tee /data/hive-ptest/logs/PreCommit-HIVE-TRUNK-Build-275/source-prep.txt
          + [[ false == \t\r\u\e ]]
          + mkdir -p maven ivy
          + [[ svn = \s\v\n ]]
          + [[ -n '' ]]
          + [[ -d apache-svn-trunk-source ]]
          + [[ ! -d apache-svn-trunk-source/.svn ]]
          + [[ ! -d apache-svn-trunk-source ]]
          + cd apache-svn-trunk-source
          + svn revert -R .
          Reverted 'itests/util/src/main/java/org/apache/hadoop/hive/ql/QTestUtil.java'
          Reverted 'ql/src/java/org/apache/hadoop/hive/ql/hooks/EnforceReadOnlyTables.java'
          ++ egrep -v '^X|^Performing status on external'
          ++ awk '{print $2}'
          ++ svn status --no-ignore
          + rm -rf target datanucleus.log ant/target shims/target shims/0.20/target shims/0.20S/target shims/0.23/target shims/aggregator/target shims/common/target shims/common-secure/target packaging/target hbase-handler/target testutils/target jdbc/target metastore/target itests/target itests/hcatalog-unit/target itests/test-serde/target itests/qtest/target itests/hive-unit-hadoop2/target itests/hive-minikdc/target itests/hive-unit/target itests/custom-serde/target itests/util/target hcatalog/target hcatalog/core/target hcatalog/streaming/target hcatalog/server-extensions/target hcatalog/webhcat/svr/target hcatalog/webhcat/java-client/target hcatalog/hcatalog-pig-adapter/target hwi/target common/target common/src/gen contrib/target service/target serde/target beeline/target odbc/target cli/target ql/dependency-reduced-pom.xml ql/target
          + svn update
          
          Fetching external item into 'hcatalog/src/test/e2e/harness'
          External at revision 1617532.
          
          At revision 1617532.
          + patchCommandPath=/data/hive-ptest/working/scratch/smart-apply-patch.sh
          + patchFilePath=/data/hive-ptest/working/scratch/build.patch
          + [[ -f /data/hive-ptest/working/scratch/build.patch ]]
          + chmod +x /data/hive-ptest/working/scratch/smart-apply-patch.sh
          + /data/hive-ptest/working/scratch/smart-apply-patch.sh /data/hive-ptest/working/scratch/build.patch
          The patch does not appear to apply with p0, p1, or p2
          + exit 1
          '
          

          This message is automatically generated.

          ATTACHMENT ID: 12661199

          Lefty Leverenz added a comment -

          +1 as far as doc issues go

          Szehon Ho added a comment -

          +1, looks good to me

          Szehon Ho added a comment -

          Patch needs rebase

          Vaibhav Gumashta added a comment -

          Patch rebased on trunk

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12662468/HIVE-7353.4.patch

          ERROR: -1 due to 40 failed/errored test(s), 5750 tests executed
          Failed tests:

          org.apache.hadoop.hive.metastore.TestMetastoreVersion.testVersionMisMatch
          org.apache.hive.beeline.TestBeeLineWithArgs.testEmbeddedBeelineConnection
          org.apache.hive.jdbc.TestJdbcDriver2.org.apache.hive.jdbc.TestJdbcDriver2
          org.apache.hive.jdbc.TestJdbcWithMiniHS2.org.apache.hive.jdbc.TestJdbcWithMiniHS2
          org.apache.hive.jdbc.TestJdbcWithMiniMr.org.apache.hive.jdbc.TestJdbcWithMiniMr
          org.apache.hive.jdbc.TestSSL.testConnectionMismatch
          org.apache.hive.jdbc.TestSSL.testInvalidConfig
          org.apache.hive.jdbc.TestSSL.testSSLConnectionWithProperty
          org.apache.hive.jdbc.TestSSL.testSSLConnectionWithURL
          org.apache.hive.jdbc.TestSSL.testSSLFetch
          org.apache.hive.jdbc.TestSSL.testSSLFetchHttp
          org.apache.hive.jdbc.authorization.TestHS2AuthzContext.org.apache.hive.jdbc.authorization.TestHS2AuthzContext
          org.apache.hive.jdbc.authorization.TestHS2AuthzSessionContext.org.apache.hive.jdbc.authorization.TestHS2AuthzSessionContext
          org.apache.hive.jdbc.authorization.TestJdbcWithSQLAuthorization.org.apache.hive.jdbc.authorization.TestJdbcWithSQLAuthorization
          org.apache.hive.jdbc.miniHS2.TestHiveServer2.testConnection
          org.apache.hive.jdbc.miniHS2.TestHiveServer2.testGetVariableValue
          org.apache.hive.jdbc.miniHS2.TestMiniHS2.testConfInSession
          org.apache.hive.minikdc.TestHs2HooksWithMiniKdc.org.apache.hive.minikdc.TestHs2HooksWithMiniKdc
          org.apache.hive.minikdc.TestJdbcWithMiniKdc.org.apache.hive.minikdc.TestJdbcWithMiniKdc
          org.apache.hive.minikdc.TestJdbcWithMiniKdcSQLAuthBinary.org.apache.hive.minikdc.TestJdbcWithMiniKdcSQLAuthBinary
          org.apache.hive.minikdc.TestJdbcWithMiniKdcSQLAuthHttp.org.apache.hive.minikdc.TestJdbcWithMiniKdcSQLAuthHttp
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testConfOverlay
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testExecuteStatement
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testExecuteStatementAsync
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testGetFunctions
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testGetInfo
          org.apache.hive.service.cli.TestEmbeddedThriftBinaryCLIService.testOpenSession
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFile
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFileAndConfOverlay
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFileWithUser
          org.apache.hive.service.cli.session.TestSessionHooks.testProxyUser
          org.apache.hive.service.cli.session.TestSessionHooks.testSessionHook
          org.apache.hive.service.cli.thrift.TestThriftBinaryCLIService.testExecuteStatement
          org.apache.hive.service.cli.thrift.TestThriftBinaryCLIService.testExecuteStatementAsync
          org.apache.hive.service.cli.thrift.TestThriftBinaryCLIService.testGetFunctions
          org.apache.hive.service.cli.thrift.TestThriftBinaryCLIService.testOpenSession
          org.apache.hive.service.cli.thrift.TestThriftHttpCLIService.testExecuteStatement
          org.apache.hive.service.cli.thrift.TestThriftHttpCLIService.testExecuteStatementAsync
          org.apache.hive.service.cli.thrift.TestThriftHttpCLIService.testGetFunctions
          org.apache.hive.service.cli.thrift.TestThriftHttpCLIService.testOpenSession
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/381/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/381/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-381/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 40 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12662468

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12663983/HIVE-7353.5.patch

          ERROR: -1 due to 7 failed/errored test(s), 6118 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_auto_sortmerge_join_8
          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_schemeAuthority
          org.apache.hadoop.hive.metastore.TestMetastoreVersion.testVersionMisMatch
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFile
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFileAndConfOverlay
          org.apache.hive.service.cli.session.TestSessionGlobalInitFile.testSessionGlobalInitFileWithUser
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/479/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/479/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-479/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 7 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12663983

          Vaibhav Gumashta added a comment -

          Szehon Ho Failures look unrelated to me. Can you also take a look?

          Szehon Ho added a comment -

          Hi Vaibhav Gumashta I dont see the TestSessionGlobalInitFile failures in the other runs, can you take a look?

          Vaibhav Gumashta added a comment -

          Szehon Ho This should fix it.

          Szehon Ho added a comment -

          Thanks, do you mind updating the RB as well?

          Vaibhav Gumashta added a comment -

          Szehon Ho Done that already. Actually hold off on reviewing this one for few mins - I see one issue with the current patch - I'll put up an updated one in few mins.

          Vaibhav Gumashta added a comment -

          Szehon Ho Feel free to review this now. Thanks!

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12664425/HIVE-7353.7.patch

          ERROR: -1 due to 4 failed/errored test(s), 6115 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          org.apache.hadoop.hive.metastore.TestMetastoreVersion.testVersionMisMatch
          org.apache.hive.hcatalog.pig.TestOrcHCatLoader.testReadDataPrimitiveTypes
          org.apache.hive.jdbc.miniHS2.TestHiveServer2.testConnection
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/508/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/508/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-508/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 4 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12664425

          Szehon Ho added a comment -

          Thanks, +1 on latest patch pending tests.

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12664493/HIVE-7353.8.patch

          ERROR: -1 due to 2 failed/errored test(s), 6115 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          org.apache.hadoop.hive.metastore.TestMetastoreVersion.testVersionMisMatch
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/513/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/513/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-513/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 2 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12664493

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12664687/HIVE-7353.9.patch

          ERROR: -1 due to 1 failed/errored test(s), 6119 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_dynpart_sort_opt_vectorization
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/530/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/530/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-530/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12664687

          Vaibhav Gumashta added a comment -

          The test failure doesn't seem to be related - it's been failing on other precommits too. I'll commit this in a while.

          Vaibhav Gumashta added a comment -

          Patch committed to trunk.

          Thanks for the reviews Szehon Ho, Lefty Leverenz and Navis

          Lefty Leverenz added a comment -

          This adds configuration parameters hive.server2.thrift.worker.keepalive.time and hive.server2.thrift.http.worker.keepalive.time so they need to be documented in the wiki, preferably after these related parameters:

          Lefty Leverenz added a comment -

          Vaibhav Gumashta, why did you remove the TODOC14 label? I don't see the new parameters in the Configuration Properties wikidoc yet.

          Are they being removed by another jira ticket? I still see them in trunk and branch-0.14.

          Vaibhav Gumashta added a comment -

          Lefty Leverenz Ah, didn't realize that a parameter was added here. Adding back the todoc tag. Thanks for pointing out!

          Szehon Ho added a comment -

          Added description (verbatim) for :
          hive.server2.thrift.http.worker.keepalive.time, hive.server2.thrift.worker.keepalive.time

          at specified location at https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties

          FYI Lefty Leverenz. Also I assume we are removing TODOC label after doc but before you review, hope thats right.

          Lefty Leverenz added a comment -

          ... we are removing TODOC label after doc but before you review ...

          That's fine because my reviews generally turn up trivial edits that don't affect doc usability. (On the other hand when I write doc, it makes sense to keep the label pending expert review.)

          Today's flood of documentation is very encouraging – thanks all! I'll get to the reviews as soon as I can, and tackle the backlist too.

          Thejas M Nair added a comment -

          This has been fixed in 0.14 release. Please open new jira if you see any issues.


            People

            • Assignee:
              Vaibhav Gumashta
              Reporter:
              Vaibhav Gumashta
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development