Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-6960

Set Hive pom to use Hadoop-2.4

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.14.0
    • Fix Version/s: 0.14.0
    • Component/s: Build Infrastructure
    • Labels:
      None

      Description

      A number of the hadoop-2 unit test failures are due to HADOOP-10425, fixed in Hadoop 2.4. Perhaps we should move onto that version.

      • org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_nullgroup3
      • org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_join4
      • org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_select_dummy_source
      • org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_symlink_text_input_format
      • org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_udf_current_database
      • org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_bucketizedhiveinputformat

        Attachments

        1. HIVE-6960.2.patch
          21 kB
          Jason Dere
        2. HIVE-6960.1.patch
          0.6 kB
          Jason Dere
        3. HIVE-6960.1.patch
          0.6 kB
          Jason Dere

          Issue Links

            Activity

              People

              • Assignee:
                jdere Jason Dere
                Reporter:
                jdere Jason Dere
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: