Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-6912

HWI not working - HTTP ERROR 500

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

      I tried to use hive HWI to write hive queries on a UI.
      As p[er the steps mentioned here https://cwiki.apache.org/confluence/display/Hive/HiveWebInterface
      I set Ant and ran the hive hwi service.

      but In browser when i hit http://localhost:9999/hwi i got the below error
      HTTP ERROR 500

      Problem accessing /hwi/. Reason:

      Unable to find a javac compiler;
      com.sun.tools.javac.Main is not on the classpath.
      Perhaps JAVA_HOME does not point to the JDK.
      It is currently set to "/usr/java/jdk1.6.0_32/jre"
      Caused by:

      Unable to find a javac compiler;
      com.sun.tools.javac.Main is not on the classpath.
      Perhaps JAVA_HOME does not point to the JDK.
      It is currently set to "/usr/java/jdk1.6.0_32/jre"
      at org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCompiler(CompilerAdapterFactory.java:129)

      I have checked and changed JAVA_HOME. But its still the same

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                skhuntia@sapient.com sunil ranjan khuntia
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: