Hive
  1. Hive
  2. HIVE-6880

TestHWISessionManager fails with -Phadoop-2

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.13.0
    • Fix Version/s: 0.14.0
    • Component/s: Tests
    • Labels:
      None

      Description

      Looks like dependencies missing for -Phadoop-2

      Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.213 sec <<< FAILURE! - in org.apache.hadoop.hive.hwi.TestHWISessionManager
      warning(junit.framework.TestSuite$1)  Time elapsed: 0.009 sec  <<< FAILURE!
      junit.framework.AssertionFailedError: Exception in constructor: testHiveDriver (java.lang.NoClassDefFoundError: org/apache/hadoop/mapreduce/TaskAttemptContext
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Class.java:171)
      	at org.apache.hadoop.hive.shims.ShimLoader.createShim(ShimLoader.java:120)
      	at org.apache.hadoop.hive.shims.ShimLoader.loadShims(ShimLoader.java:115)
      	at org.apache.hadoop.hive.shims.ShimLoader.getHadoopShims(ShimLoader.java:80)
      	at org.apache.hadoop.hive.conf.HiveConf$ConfVars.<clinit>(HiveConf.java:248)
      	at org.apache.hadoop.hive.conf.HiveConf.<clinit>(HiveConf.java:81)
      	at org.apache.hadoop.hive.hwi.TestHWISessionManager.<init>(TestHWISessionManager.java:46)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      	at junit.framework.TestSuite.createTest(TestSuite.java:65)
      	at junit.framework.TestSuite.addTestMethod(TestSuite.java:294)
      	at junit.framework.TestSuite.addTestsFromTestCase(TestSuite.java:150)
      	at junit.framework.TestSuite.<init>(TestSuite.java:129)
      	at org.junit.internal.runners.JUnit38ClassRunner.<init>(JUnit38ClassRunner.java:71)
      	at org.junit.internal.builders.JUnit3Builder.runnerForClass(JUnit3Builder.java:14)
      	at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:57)
      	at org.junit.internal.builders.AllDefaultPossibilitiesBuilder.runnerForClass(AllDefaultPossibilitiesBuilder.java:29)
      	at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:57)
      	at org.junit.internal.requests.ClassRequest.getRunner(ClassRequest.java:24)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.execute(JUnit4Provider.java:262)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.executeTestSet(JUnit4Provider.java:153)
      	at org.apache.maven.surefire.junit4.JUnit4Provider.invoke(JUnit4Provider.java:124)
      	at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:200)
      	at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:153)
      	at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:103)
      Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.mapreduce.TaskAttemptContext
      	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	... 28 more
      )
      	at junit.framework.Assert.fail(Assert.java:50)
      	at junit.framework.TestSuite$1.runTest(TestSuite.java:97)
      

        Activity

        Thejas M Nair added a comment -

        This has been fixed in 0.14 release. Please open new jira if you see any issues.

        Ashutosh Chauhan added a comment -

        Committed to trunk. Thanks, Jason!

        Hive QA added a comment -

        Overall: +1 all checks pass

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12639512/HIVE-6880.1.patch

        SUCCESS: +1 5571 tests passed

        Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/2206/testReport
        Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/2206/console

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Executing org.apache.hive.ptest.execution.ExecutionPhase
        Executing org.apache.hive.ptest.execution.ReportingPhase
        

        This message is automatically generated.

        ATTACHMENT ID: 12639512

        Ashutosh Chauhan added a comment -

        +1


          People

          • Assignee:
            Jason Dere
            Reporter:
            Jason Dere
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development