Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: Configuration
    • Labels:
      None

      Description

      with set hive.conf.validation=true, hive validates new value can be changed to the type. But it does not check value itself.

      1. D13821.1.patch
        11 kB
        Phabricator
      2. D13821.2.patch
        11 kB
        Phabricator

        Issue Links

          Activity

          Navis created issue -
          Phabricator added a comment -

          navis requested code review of "HIVE-5707 [jira] Validate values for ConfVar".

          Reviewers: JIRA

          HIVE-5707 Validate values for ConfVar

          with set hive.conf.validation=true, hive validates new value can be changed to the type. But it does not check value itself.

          TEST PLAN
          EMPTY

          REVISION DETAIL
          https://reviews.facebook.net/D13821

          AFFECTED FILES
          common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
          ql/src/java/org/apache/hadoop/hive/ql/processors/SetProcessor.java
          ql/src/test/queries/clientnegative/set_hiveconf_validation2.q
          ql/src/test/results/clientnegative/set_hiveconf_validation2.q.out

          WHY DID I GET THIS EMAIL?
          https://reviews.facebook.net/herald/transcript/41961/

          To: JIRA, navis

          Phabricator made changes -
          Field Original Value New Value
          Attachment D13821.1.patch [ 12611260 ]
          Navis made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12611260/D13821.1.patch

          ERROR: -1 due to 2 failed/errored test(s), 4548 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_orc_create
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_bucket_num_reducers
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/92/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/92/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests failed with: TestsFailedException: 2 tests failed
          

          This message is automatically generated.

          Phabricator added a comment -

          navis updated the revision "HIVE-5707 [jira] Validate values for ConfVar".

          Fixed orc_create (cannot reproduce fail of bucket_num_reducers)

          Reviewers: JIRA

          REVISION DETAIL
          https://reviews.facebook.net/D13821

          CHANGE SINCE LAST DIFF
          https://reviews.facebook.net/D13821?vs=42753&id=42861#toc

          AFFECTED FILES
          common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
          ql/src/java/org/apache/hadoop/hive/ql/processors/SetProcessor.java
          ql/src/test/queries/clientnegative/set_hiveconf_validation2.q
          ql/src/test/queries/clientpositive/orc_create.q
          ql/src/test/results/clientnegative/set_hiveconf_validation2.q.out

          To: JIRA, navis

          Phabricator made changes -
          Attachment D13821.2.patch [ 12611565 ]
          Hive QA added a comment -

          Overall: +1 all checks pass

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12611565/D13821.2.patch

          SUCCESS: +1 4548 tests passed

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/109/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/109/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          

          This message is automatically generated.

          Brock Noland added a comment -

          +1

          Brock Noland added a comment -

          Thank you for the contribution Navis! I have committed this to trunk!

          Brock Noland made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Fix Version/s 0.13.0 [ 12324986 ]
          Resolution Fixed [ 1 ]
          Lefty Leverenz made changes -
          Link This issue relates to HIVE-2848 [ HIVE-2848 ]

            People

            • Assignee:
              Navis
              Reporter:
              Navis
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development