Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-5385

StringUtils is not in commons codec 1.3

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

      In ThriftHttpServlet introduced by HIVE-4763, StringUtils is imported which was introduced by commons codec 1.4. But, our 0.20 shims depends on commons codec 1.3. Our eclipse classpath template is also using libs of 0.20 shims. So, we will get two errors in eclipse.

      Compiling hive will not have a problem because we are loading codec 1.4 for project service (1.4 is also used when "-Dhadoop.version=0.20.2 -Dhadoop.mr.rev=20").

        Attachments

        1. HIVE-5385.1.patch
          0.9 kB
          Kousuke Saruta
        2. HIVE-5385.2.patch
          3 kB
          Kousuke Saruta

          Activity

            People

            • Assignee:
              sarutak Kousuke Saruta
              Reporter:
              yhuai Yin Huai
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: