Hive
  1. Hive
  2. HIVE-5359

HiveAuthFactory does not honor the hive configuration passed while creating HiveServer2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: HiveServer2
    • Labels:
      None

      Description

      When HS2 is brought up, the server can be inited with the given hive config: HiveServer2#init(HiveConf hiveConf). That configuration should be applied through the entire setup process for all services. However, while starting ThriftCLIService, it creates a new HiveAuthFactory object, whose constructor creates a new HiveConf object and ends up using it rather than using the HiveConf passed during HS2 bootstrap.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        376d 13h 11m 1 Vaibhav Gumashta 07/Oct/14 08:40
        Vaibhav Gumashta made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Vaibhav Gumashta added a comment -

        This has been fixed by some more recent work.

        Vaibhav Gumashta made changes -
        Field Original Value New Value
        Description When HS2 is brought up, the server can be inited with the given hive config: HiveServer2#init(HiveConf hiveConf). That configuration should be applied through the entire setup process for all services. However, while starting ThriftBinaryCLIService, it creates a new HiveAuthFactory object, whose constructor creates a new HiveConf object and ends up using it rather than using the HiveConf passed during HS2 bootstrap. When HS2 is brought up, the server can be inited with the given hive config: HiveServer2#init(HiveConf hiveConf). That configuration should be applied through the entire setup process for all services. However, while starting ThriftCLIService, it creates a new HiveAuthFactory object, whose constructor creates a new HiveConf object and ends up using it rather than using the HiveConf passed during HS2 bootstrap.
        Vaibhav Gumashta created issue -

          People

          • Assignee:
            Vaibhav Gumashta
            Reporter:
            Vaibhav Gumashta
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development