Hive
  1. Hive
  2. HIVE-4825

Separate MapredWork into MapWork and ReduceWork

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.12.0
    • Component/s: None
    • Labels:
      None

      Description

      Right now all the information needed to run an MR job is captured in MapredWork. This class has aliases, tagging info, table descriptors etc.

      For Tez and MRR it will be useful to break this into map and reduce specific pieces. The separation is natural and I think has value in itself, it makes the code easier to understand. However, it will also allow us to reuse these abstractions in Tez where you'll have a graph of these instead of just 1M and 0-1R.

      1. HIVE-4825.1.patch
        361 kB
        Gunther Hagleitner
      2. HIVE-4825.2.code.patch
        200 kB
        Gunther Hagleitner
      3. HIVE-4825.2.testfiles.patch
        1.71 MB
        Gunther Hagleitner
      4. HIVE-4825.3.testfiles.patch
        1.71 MB
        Gunther Hagleitner
      5. HIVE-4825.4.patch
        1.90 MB
        Gunther Hagleitner
      6. HIVE-4825.5.patch
        1.90 MB
        Gunther Hagleitner
      7. HIVE-4825.6.patch
        1.91 MB
        Gunther Hagleitner

        Issue Links

          Activity

          Gunther Hagleitner created issue -
          Gunther Hagleitner made changes -
          Field Original Value New Value
          Link This issue blocks HIVE-4660 [ HIVE-4660 ]
          Gunther Hagleitner added a comment -
          Gunther Hagleitner made changes -
          Attachment HIVE-4825.1.patch [ 12591326 ]
          Gunther Hagleitner made changes -
          Attachment HIVE-4825.2.code.patch [ 12592282 ]
          Attachment HIVE-4825.2.testfiles.patch [ 12592283 ]
          Gunther Hagleitner added a comment -

          Ran tests on 1 & 2 line. Came back clean. Split in code + test, because there's lots of whitespace only diffs. I've also updated the review.

          Gunther Hagleitner made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Edward Capriolo added a comment -

          This issues is NOT a bug. It's priority is not major.

          Edward Capriolo made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          Priority Major [ 3 ] Minor [ 4 ]
          Edward Capriolo added a comment -

          Also to not commit on trunk if this is only a tez supporting patch. There is a tez branch.

          Gunther Hagleitner added a comment -

          Reran tests. Missed one file. .2 code patch is still good.

          Gunther Hagleitner made changes -
          Attachment HIVE-4825.3.testfiles.patch [ 12592505 ]
          Ashutosh Chauhan added a comment -

          As far as I can see, there is nothing Tez specific in this patch. Its welcome change to improve state of the art of Hive trunk. Edward Capriolo are you -1ing this patch for trunk?

          Gunther Hagleitner added a comment -

          .4 is rebased to trunk

          Gunther Hagleitner made changes -
          Attachment HIVE-4825.4.patch [ 12593669 ]
          Hive QA added a comment -

          Overall: -1 no tests executed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12593669/HIVE-4825.4.patch

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/149/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/149/console

          Messages:

          Executing org.apache.hive.ptest.execution.CleanupPhase
          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Tests failed with: IllegalStateException: Too many bad hosts: 1.0% (10 / 10) is greater than threshold of 50%
          

          This message is automatically generated.

          Brock Noland added a comment -

          There was a large price spike in spot instances overnight. I kicked this off again. Also that error message needs to be cleaned up.

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12593669/HIVE-4825.4.patch

          ERROR: -1 due to 1 failed/errored test(s), 2647 tests executed
          Failed tests:

          org.apache.hcatalog.fileformats.TestOrcDynamicPartitioned.testHCatDynamicPartitionedTableMultipleTask
          

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/150/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/150/console

          Messages:

          Executing org.apache.hive.ptest.execution.CleanupPhase
          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests failed with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          Gunther Hagleitner added a comment -

          Surprised to see this hcat test fail - shouldn't be affected by the changes. Ran it in isolation a few times and also ran all hcat tests combined. Couldn't reproduce the issue. Fluke?

          Brock Noland added a comment -

          Yes I believe that one is flaky. I added it to HIVE-4851

          Edward Capriolo added a comment -

          Huge effort. I do see what your saying. The win is nice in that something is either MapWork or ReduceWork and there are some classes that do not need to redundantly set reduce tasks to 0 when they run on the map side. Even though this patch touches many files it pretty much touch them all in a small way that should not be too much trouble for anyone to deal with. I am +1, most of the changes this would cause would be cosmetic. Im only trying to look out for things that Navis and Yin have on the queue.

          Ashutosh Chauhan added a comment -

          Some review comments on Phabricator.

          Ashutosh Chauhan added a comment -

          One more comment. Sorry missed that one earlier.

          Gunther Hagleitner added a comment -

          .5 is rebased to trunk + addresses Ashutosh' review comments.

          Gunther Hagleitner made changes -
          Attachment HIVE-4825.5.patch [ 12594510 ]
          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12594510/HIVE-4825.5.patch

          ERROR: -1 due to 1 failed/errored test(s), 2653 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_dynamic_partition_skip_default
          

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/205/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/205/console

          Messages:

          Executing org.apache.hive.ptest.execution.CleanupPhase
          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests failed with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          Gunther Hagleitner added a comment -

          Unfortunately, I missed updating the golden file for the new "skip default partition" testcase. Patch .6 has the update for the golden file.

          Gunther Hagleitner made changes -
          Attachment HIVE-4825.6.patch [ 12594527 ]
          Hive QA added a comment -

          Overall: +1 all checks pass

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12594527/HIVE-4825.6.patch

          SUCCESS: +1 2653 tests passed

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/208/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/208/console

          Messages:

          Executing org.apache.hive.ptest.execution.CleanupPhase
          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          

          This message is automatically generated.

          Ashutosh Chauhan added a comment -

          +1

          Ashutosh Chauhan added a comment -

          Committed to trunk. Thanks, Gunther!

          Ashutosh Chauhan made changes -
          Resolution Fixed [ 1 ]
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Fix Version/s 0.12.0 [ 12324312 ]
          Thejas M Nair made changes -
          Link This issue relates to HIVE-4955 [ HIVE-4955 ]
          Hudson added a comment -

          ABORTED: Integrated in Hive-trunk-hadoop2 #318 (See https://builds.apache.org/job/Hive-trunk-hadoop2/318/)
          HIVE-4825 : Separate MapredWork into MapWork and ReduceWork (Gunther Hagleitner via Ashutosh Chauhan) (hashutosh: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1508111)

          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/Driver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/QueryPlan.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/ExplainTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/MapOperator.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/MoveTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/ExecDriver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/ExecMapper.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/ExecReducer.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/MapRedTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/MapredLocalTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/index/compact/CompactIndexHandler.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/CombineHiveInputFormat.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/HiveInputFormat.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/SymbolicInputFormat.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/avro/AvroGenericRecordReader.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/merge/BlockMergeTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/merge/MergeWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/stats/PartialScanTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/stats/PartialScanWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/truncate/ColumnTruncateMapper.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/truncate/ColumnTruncateTask.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/io/rcfile/truncate/ColumnTruncateWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMRFileSink1.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMRRedSink1.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMRRedSink3.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMRTableScan1.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/MapJoinFactory.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/MapJoinProcessor.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/AbstractJoinTaskDispatcher.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/BucketingSortingInferenceOptimizer.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/CommonJoinTaskDispatcher.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/GenMRSkewJoinProcessor.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/MapJoinResolver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/MetadataOnlyOptimizer.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/SamplingOptimizer.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/SkewJoinResolver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/SortMergeJoinTaskDispatcher.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/index/IndexWhereProcessor.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/optimizer/physical/index/IndexWhereTaskDispatcher.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/MapReduceCompiler.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/BaseWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/ConditionalResolverMergeFiles.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/Explain.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/MapWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/MapredWork.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/PartitionDesc.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/PlanUtils.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/plan/ReduceWork.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/QTestUtil.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/exec/TestExecDriver.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/exec/TestOperators.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/exec/TestPlan.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/hooks/VerifyHiveSortedInputFormatUsedHook.java
          • /hive/trunk/ql/src/test/org/apache/hadoop/hive/ql/io/TestSymlinkTextInputFormat.java
          • /hive/trunk/ql/src/test/results/clientpositive/alter_partition_coltype.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_11.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_12.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/auto_sortmerge_join_8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/binary_output_format.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket_map_join_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucket_map_join_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_6.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketcontext_8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin10.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin11.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin12.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin13.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin_negative.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin_negative2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/bucketmapjoin_negative3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/columnstats_partlvl.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/columnstats_tbllvl.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/combine2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/combine2_hadoop20.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/ctas.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/ctas_hadoop20.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/disable_merge_for_bucketing.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/dynamic_partition_skip_default.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/filter_join_breaktask.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_map_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_map_ppr_multi_distinct.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_ppr_multi_distinct.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_sort_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_sort_6.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/groupby_sort_skew_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input23.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input42.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input_part1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input_part2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input_part7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/input_part9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join17.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join26.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join32.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join32_lessSize.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join33.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join34.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join35.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join_filters_overlap.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/join_map_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_10.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_11.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_12.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_13.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_6.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_dml_9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_multiskew_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_multiskew_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_multiskew_3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_oneskew_1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_oneskew_2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/list_bucket_query_oneskew_3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/load_dyn_part8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/louter_join_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/macro.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/merge3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/metadataonly1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/outer_join_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/parallel_orderby.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/pcr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/plan_json.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/ppd_join_filter.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/ppd_union_view.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/ppr_allchildsarenull.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/rand_partitionpruner1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/rand_partitionpruner2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/rand_partitionpruner3.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/reduce_deduplicate.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/regexp_extract.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/router_join_ppr.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample10.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample4.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample6.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample8.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sample9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/smb_mapjoin9.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/smb_mapjoin_11.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/smb_mapjoin_12.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/smb_mapjoin_13.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/smb_mapjoin_15.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sort_merge_join_desc_5.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sort_merge_join_desc_6.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/sort_merge_join_desc_7.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/stats0.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/stats11.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/stats12.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/stats13.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/transform_ppr1.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/transform_ppr2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/truncate_column_list_bucket.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/udf_explode.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/udf_java_method.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/udf_reflect.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/udf_reflect2.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/udtf_explode.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/union22.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/union24.q.out
          • /hive/trunk/ql/src/test/results/clientpositive/union_ppr.q.out
          • /hive/trunk/ql/src/test/results/compiler/plan/case_sensitivity.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/cast1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby2.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby3.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby4.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby5.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/groupby6.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input2.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input20.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input3.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input4.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input5.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input6.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input7.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input8.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input9.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input_part1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input_testsequencefile.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input_testxpath.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/input_testxpath2.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join2.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join3.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join4.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join5.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join6.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join7.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/join8.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample2.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample3.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample4.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample5.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample6.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/sample7.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/subq.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/udf1.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/udf4.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/udf6.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/udf_case.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/udf_when.q.xml
          • /hive/trunk/ql/src/test/results/compiler/plan/union.q.xml
          Ashutosh Chauhan added a comment -

          This issue has been fixed and released as part of 0.12 release. If you find further issues, please create a new jira and link it to this one.

          Ashutosh Chauhan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Gunther Hagleitner
              Reporter:
              Gunther Hagleitner
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development