Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-4030

Name windowing function in consistence with sql standard

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.11.0
    • Component/s: PTF-Windowing
    • Labels:
      None

      Description

      Currently we name them as denserank, percentrank, rownumber, cumedist. SQL standard says that they should be named as dense_rank, percent_rank, row_number, cume_dist.

        Attachments

        1. hive-4030.patch
          40 kB
          Ashutosh Chauhan

          Issue Links

            Activity

              People

              • Assignee:
                ashutoshc Ashutosh Chauhan
                Reporter:
                ashutoshc Ashutosh Chauhan
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: