Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-4003

NullPointerException in exec.Utilities

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.12.0, 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

      Utilities.java seems to be throwing a NPE.

      Change contributed by Thomas Adam.

      Reference: https://github.com/tecbot/hive/commit/1e29d88837e4101a76e870a716aadb729437355b#commitcomment-2588350

      1. HIVE-4003.patch
        0.7 kB
        Mark Grover
      2. HIVE-4003.patch
        0.8 kB
        Thomas Adam

        Activity

        ashutoshc Ashutosh Chauhan added a comment -

        This issue has been fixed and released as part of 0.12 release. If you find further issues, please create a new jira and link it to this one.

        hudson Hudson added a comment -

        ABORTED: Integrated in Hive-trunk-hadoop2 #419 (See https://builds.apache.org/job/Hive-trunk-hadoop2/419/)
        HIVE-4003 - NullPointerException in exec.Utilities (Mark Grover via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1521188)

        • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hive-trunk-h0.21 #2322 (See https://builds.apache.org/job/Hive-trunk-h0.21/2322/)
        HIVE-4003 - NullPointerException in exec.Utilities (Mark Grover via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1521188)

        • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hive-trunk-hadoop1-ptest #158 (See https://builds.apache.org/job/Hive-trunk-hadoop1-ptest/158/)
        HIVE-4003 - NullPointerException in exec.Utilities (Mark Grover via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1521188)

        • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hive-trunk-hadoop2-ptest #90 (See https://builds.apache.org/job/Hive-trunk-hadoop2-ptest/90/)
        HIVE-4003 - NullPointerException in exec.Utilities (Mark Grover via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1521188)

        • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/Utilities.java
        mgrover Mark Grover added a comment -

        Thank you!

        brocknoland Brock Noland added a comment -

        Committed to trunk and 0.12! Thank you for your contribution!

        appodictic Edward Capriolo added a comment -

        I marked it as blocker, if I do not get to it someone else should.

        mgrover Mark Grover added a comment -

        Edward Capriolo or Brock Noland would one of you mind committing this?

        lars_francke Lars Francke added a comment -

        Could we get this in for the 0.12 release?

        In addition to the positive result of the Hadoop QA bot I've been using this in production for weeks without problems.

        hiveqa Hive QA added a comment -

        Overall: +1 all checks pass

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12597856/HIVE-4003.patch

        SUCCESS: +1 2856 tests passed

        Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/432/testReport
        Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/432/console

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Executing org.apache.hive.ptest.execution.ExecutionPhase
        Executing org.apache.hive.ptest.execution.ReportingPhase
        

        This message is automatically generated.

        appodictic Edward Capriolo added a comment -

        +1 pending tests.

        mgrover Mark Grover added a comment -

        I am guessing I have to keep the name of the patch same, so tests can be run. Correcting the name to be HIVE-4003.patch now.

        mgrover Mark Grover added a comment -

        Uploaded a new rebased patch.

        mgrover Mark Grover added a comment -

        Thanks, Brock, for taking a look. I will rebase this.

        brocknoland Brock Noland added a comment -

        Hey Mark Grover thanks for the patch! Since it doesn't apply any longer can you rebase?

        hiveqa Hive QA added a comment -

        Overall: -1 no tests executed

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12568605/HIVE-4003.patch

        Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/419/testReport
        Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/419/console

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Tests failed with: NonZeroExitCodeException: Command 'bash /data/hive-ptest/working/scratch/source-prep.sh' failed with exit status 1 and output '+ [[ -n '' ]]
        + export 'ANT_OPTS=-Xmx1g -XX:MaxPermSize=256m -Dhttp.proxyHost=localhost -Dhttp.proxyPort=3128'
        + ANT_OPTS='-Xmx1g -XX:MaxPermSize=256m -Dhttp.proxyHost=localhost -Dhttp.proxyPort=3128'
        + cd /data/hive-ptest/working/
        + tee /data/hive-ptest/logs/PreCommit-HIVE-Build-419/source-prep.txt
        + mkdir -p maven ivy
        + [[ svn = \s\v\n ]]
        + [[ -n '' ]]
        + [[ -d apache-svn-trunk-source ]]
        + [[ ! -d apache-svn-trunk-source/.svn ]]
        + [[ ! -d apache-svn-trunk-source ]]
        + cd apache-svn-trunk-source
        + svn revert -R .
        ++ egrep -v '^X|^Performing status on external'
        ++ awk '{print $2}'
        ++ svn status --no-ignore
        + rm -rf
        + svn update
        
        Fetching external item into 'hcatalog/src/test/e2e/harness'
        External at revision 1513535.
        
        At revision 1513535.
        + patchCommandPath=/data/hive-ptest/working/scratch/smart-apply-patch.sh
        + patchFilePath=/data/hive-ptest/working/scratch/build.patch
        + [[ -f /data/hive-ptest/working/scratch/build.patch ]]
        + chmod +x /data/hive-ptest/working/scratch/smart-apply-patch.sh
        + /data/hive-ptest/working/scratch/smart-apply-patch.sh /data/hive-ptest/working/scratch/build.patch
        The patch does not appear to apply with p0 to p2
        + exit 1
        '
        

        This message is automatically generated.

        brocknoland Brock Noland added a comment -

        Marking "Patch Available" to get a test run.

        kovyrin Alexey Kovyrin added a comment -

        Any updates on this issue?

        tecbot Thomas Adam added a comment -

        Thank you Mark.

        mgrover Mark Grover added a comment -

        Ok, in that case, I can take it on from here. Thanks for your contribution, Thomas!

        tecbot Thomas Adam added a comment -

        Sorry no, I'm not familiar with the code and I have nothing usually to do with java.

        namit Namit Jain added a comment -

        Can you add a test ?

        tecbot Thomas Adam added a comment -

        I updated today the hive version to git master of my cdh cluster (4.1.2) to get this patch HIVE-3699.

        mgrover Mark Grover added a comment -

        Thanks Thomas. Could you point out how one can reproduce the error?


          People

          • Assignee:
            mgrover Mark Grover
            Reporter:
            tecbot Thomas Adam
          • Votes:
            3 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development