njain has commented on the revision "HIVE-3946 [jira] Make it possible to configure for each stage".
ql/src/java/org/apache/hadoop/hive/ql/Driver.java:1351 Can you add a lot of comments ?
ql/src/test/queries/clientpositive/config_per_stage.q:1 This might be fairly difficult to maintain for an application.
I mean, the query plans change so many times due to random optimizations,
because of which old stage numbers will become invalid.
It is a very good idea, but can you think of a better naming scheme.
I dont have any suggestion right now.
ql/src/test/queries/clientpositive/config_per_stage.q:4 Can you change it to have stage-3 ?
I mean, the stage-2. parameters should be overridden by defaults ?
To: JIRA, navis