Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.10.0
    • Component/s: SQL
    • Labels:
      None
    • Environment:

      hive 0.9 bin, and postgres as metadata.

      Description

      Setup a new hive 0.9 client, follow this steps

      hive> create table t1(a int) partitioned by ( dt int );
      OK
      Time taken: 0.097 seconds
      hive> load data local inpath '/tmp/t' into table t1 partition (dt=111);
      Copying data from file:/tmp/t
      Copying file: file:/tmp/t
      Loading data to table default.t1 partition (dt=111)
      OK
      Time taken: 0.375 seconds
      hive> show partitions t1;
      OK
      dt=111
      Time taken: 0.108 seconds
      hive> alter table t1 drop partition ( dt=111 );
      FAILED: Error in semantic analysis: Partition not found dt = 111
      hive> alter table t1 drop partition ( dt='111' );
      FAILED: Error in semantic analysis: Partition not found dt = '111'

      after change partition column type to string, it's worked.

        Activity

        Ashutosh Chauhan added a comment -

        Dupe of HIVE-3063 ?

        wd added a comment -

        Yes。 I've searched before posting, but didn't see it. Sorry for this post.

        Ashutosh Chauhan added a comment -

        This issue is fixed and released as part of 0.10.0 release. If you find an issue which seems to be related to this one, please create a new jira and link this one with new jira.


          People

          • Assignee:
            Unassigned
            Reporter:
            wd
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development