Hive
  1. Hive
  2. HIVE-3053

Hive stopped working when new updates were installed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 0.7.1
    • Fix Version/s: None
    • Component/s: Configuration
    • Labels:
    • Environment:

      Hadoop on Ubuntu 10 LTS; Hive 0.7.1

      Description

      After a recent update (using only cloudera's patches/releases), the hive command and hive prompt stopped working. It throws these (java) errors instead:

      log4j:ERROR Could not find value for key log4j.appender.NullAppender
      log4j:ERROR Could not instantiate appender named "NullAppender".
      hive-log4j.properties not found
      Hive history file=/location/job_id.txt
      12/05/25 09:56:56 INFO exec.HiveHistory: Hive history file=/location/job_id.txt

      I am not sure how to proceed with root cause. Could somebody please check on this as soon as possible?

        Activity

        Vikas Deshpande added a comment -

        Hi Edward,

        Thanks for the response. The problem was actually that the patch took longer than normal to update on all the nodes of the cluster and hence was not working fine. It works now though it still shows "hive-log4j.properties not found".

        Thanks,
        Vikas

        Edward Capriolo added a comment -

        Here is only the place to get support for apache release versions of hive. IF you are running a patched hive it is better to contact the vendor (Cloudera) because they likely have errata on the issue. If you are getting an error like hive-log4j.properties not found you likely have a classpath issue and your install is not finding your conf directory.


          People

          • Assignee:
            Unassigned
            Reporter:
            Vikas Deshpande
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development