Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Documentation
    • Labels:
      None
    • Release Note:
      wiki has been updated. resolve the issue.

      Description

      ant gen-test fails in <hive-root>/ql.

      Expected behavior
      =================
      BUILD SUCCESSFUL

      Actual behavior
      ================
      BUILD FAILED
      ./hive/ql/build.xml:85: Problem: failed to create task or type if
      Cause: The name is undefined.
      Action: Check the spelling.
      Action: Check that any custom tasks/types have been declared.
      Action: Check that any <presetdef>/<macrodef> declarations have taken place.

      How to reproduce it
      ===================
      1. git clone git://github.com/facebook/arcanist.git
      2. ant clean package eclipse-files
      3. cd metastore/
      4. ant model-jar
      5. cd ../ql
      6. ant gen-test

      Details in https://cwiki.apache.org/confluence/display/Hive/GettingStarted+EclipseSetup

        Attachments

        1. Hive-3003.png
          47 kB
          Gang Tim Liu

          Activity

            People

            • Assignee:
              gangtimliu Gang Tim Liu
              Reporter:
              gangtimliu Gang Tim Liu
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: