Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Given the amount of push back, reverting this patch pending further changes/review seems like a good idea.

        Activity

        Kevin Wilfong created issue -
        Phabricator added a comment -

        kevinwilfong requested code review of "HIVE-3002 [jira] Revert HIVE-2986".
        Reviewers: JIRA

        https://issues.apache.org/jira/browse/HIVE-3002

        Revert HIVE-2986

        Given the amount of push back, reverting this patch pending further changes/review seems like a good idea.

        TEST PLAN
        EMPTY

        REVISION DETAIL
        https://reviews.facebook.net/D3021

        AFFECTED FILES
        contrib/src/java/org/apache/hadoop/hive/metastore
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks/AuditMetaStoreEventListener.java
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks/CounterMetaStoreEndFunctionListener.java
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks/FbhiveAlterHandler.java
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks/MysqlSmcHook.java
        contrib/src/java/org/apache/hadoop/hive/metastore/hooks/StatsManager.java
        contrib/src/java/org/apache/hadoop/hive/ql
        contrib/src/java/org/apache/hadoop/hive/ql/hooks
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/conf
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/conf/FBHiveConf.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/ExternalInputsHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/CheckRetentionsHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/JobStatsHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/StartFinishHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/AlterTableRestrictHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/QueryDroppedPartitionsHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SuggestionPrintingHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/PyRulesHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/ArchiverHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/LineageHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/BaseReplicationHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SMCStatsDBHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SmcConfigHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SmcConfigDriverRunHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/FifoPoolHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/Triple.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/CreateTableChangeDFSHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/ConfUrlFactory.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/QueryPlanHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/RegressionTestHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/AuditLocalModeHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/AuditJoinHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/JobTrackerHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SplitSizeHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/HiveConfigLoggingHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/ConnectionUrlFactory.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/AbstractSmcConfigHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/SampleConcurrencyHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/HookUtils.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/ReplicationHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/Pair.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/FbUpdateInputAccessTimeHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/hooks/CheckArchivedDataHook.java
        contrib/src/java/org/apache/hadoop/hive/ql/stats
        contrib/src/java/org/apache/hadoop/hive/ql/stats/HiveStatsMetricsPublisher.java

        MANAGE HERALD DIFFERENTIAL RULES
        https://reviews.facebook.net/herald/view/differential/

        WHY DID I GET THIS EMAIL?
        https://reviews.facebook.net/herald/transcript/6873/

        Tip: use the X-Herald-Rules header to filter Herald messages in your client.

        Phabricator made changes -
        Field Original Value New Value
        Attachment HIVE-3002.D3021.1.patch [ 12525544 ]
        Namit Jain added a comment -

        +1

        Namit Jain added a comment -

        Committed. Thanks Kevin

        Namit Jain made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hive-trunk-h0.21 #1412 (See https://builds.apache.org/job/Hive-trunk-h0.21/1412/)
        HIVE-3002 Revert HIVE-2986
        (Kevin Wilfong via namit) (Revision 1334060)

        Result = FAILURE
        namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1334060
        Files :

        • /hive/trunk/contrib/src/java/org/apache/hadoop/hive/metastore
        • /hive/trunk/contrib/src/java/org/apache/hadoop/hive/ql
        Ashutosh Chauhan made changes -
        Fix Version/s 0.10.0 [ 12320745 ]
        Ashutosh Chauhan made changes -
        Affects Version/s 0.10.0 [ 12320745 ]
        Hudson added a comment -

        Integrated in Hive-trunk-hadoop2 #54 (See https://builds.apache.org/job/Hive-trunk-hadoop2/54/)
        HIVE-3002 Revert HIVE-2986
        (Kevin Wilfong via namit) (Revision 1334060)

        Result = ABORTED
        namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1334060
        Files :

        • /hive/trunk/contrib/src/java/org/apache/hadoop/hive/metastore
        • /hive/trunk/contrib/src/java/org/apache/hadoop/hive/ql
        Ashutosh Chauhan added a comment -

        This issue is fixed and released as part of 0.10.0 release. If you find an issue which seems to be related to this one, please create a new jira and link this one with new jira.

        Ashutosh Chauhan made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Kevin Wilfong
            Reporter:
            Kevin Wilfong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development