Hive
  1. Hive
  2. HIVE-2984

Fix test failure in TestNegativeCliDriver.dyn_part_max caused by HIVE-2918

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        Carl Steinbach added a comment -

        @Kevin: I'm able to reproduce the failure by running TestNegativeCliDriver.max_dyn_parts. I'll plan to dig into this more tonight.

        Carl Steinbach added a comment -

        It looks like Ivy is picking up an older copy of the hive-metastore JAR from the local Ivy cache. I was originally able to reproduce the failure on trunk, but it now consistently passes after I manually removed the hive-metastore JAR from my .ivy2 directory. I also modified the Hive build job to run the very-clean target, and it now passes:

        https://builds.apache.org/job/Hive-trunk-h0.21/1405/

        Thomas Weise added a comment -

        Thanks Carl. Yes, the build now relies on ivy for dependencies between hive modules, so it is critical that the cache does not go stale.

        Thejas M Nair added a comment -

        Should this be closed as 'not a problem' ?

        Ashutosh Chauhan added a comment -

        This issue is fixed and released as part of 0.10.0 release. If you find an issue which seems to be related to this one, please create a new jira and link this one with new jira.


          People

          • Assignee:
            Unassigned
            Reporter:
            Carl Steinbach
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development