Hive
  1. Hive
  2. HIVE-2952

escape1.q and escape2.q failing in trunk

    Details

    • Type: Test Test
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OSX Lion

      Description

      escape1.q and escape2.q have started failing in at least the Mac OS, but they succeed in Linux

      The last time I saw them succeed in Mac was on 4/11 night

        Activity

        Kevin Wilfong made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Edward Capriolo added a comment -

        Is this the only test failing. It may be worth fixing if this is the only show stopper on mac but if there is others it might be something WONT FIX since hive expects a case sensitive file system.

        Kevin Wilfong added a comment -

        For me, it fails while trying to process the partition part=a with the exception

        [junit] org.apache.hadoop.hive.ql.metadata.HiveException: Unable to rename output from: pfile:/Users/kevinwilfong/Documents/old_hive/build/ql/scratchdir/hive_2012-04-13_17-01-55_592_712696764807580029/_task_tmp.-ext-10002/part=a/_tmp.000000_0 to: pfile:/Users/kevinwilfong/Documents/old_hive/build/ql/scratchdir/hive_2012-04-13_17-01-55_592_712696764807580029/_tmp.-ext-10002/part=a/000000_0
        [junit] at org.apache.hadoop.hive.ql.exec.FileSinkOperator$FSPaths.commit(FileSinkOperator.java:202)
        [junit] at org.apache.hadoop.hive.ql.exec.FileSinkOperator$FSPaths.access$300(FileSinkOperator.java:99)
        [junit] at org.apache.hadoop.hive.ql.exec.FileSinkOperator.closeOp(FileSinkOperator.java:720)
        [junit] at org.apache.hadoop.hive.ql.exec.Operator.close(Operator.java:557)
        [junit] at org.apache.hadoop.hive.ql.exec.Operator.close(Operator.java:566)
        [junit] at org.apache.hadoop.hive.ql.exec.Operator.close(Operator.java:566)
        [junit] at org.apache.hadoop.hive.ql.exec.Operator.close(Operator.java:566)
        [junit] at org.apache.hadoop.hive.ql.exec.ExecMapper.close(ExecMapper.java:193)
        [junit] at org.apache.hadoop.mapred.MapRunner.run(MapRunner.java:57)
        [junit] at org.apache.hadoop.mapred.MapTask.runOldMapper(MapTask.java:358)
        [junit] at org.apache.hadoop.mapred.MapTask.run(MapTask.java:307)
        [junit] at org.apache.hadoop.mapred.LocalJobRunner$Job.run(LocalJobRunner.java:176)
        [junit] Caused by: java.io.FileNotFoundException: File file:/Users/kevinwilfong/Documents/old_hive/build/ql/scratchdir/hive_2012-04-13_17-01-55_592_712696764807580029/_task_tmp.-ext-10002/part=a/_tmp.000000_0 does not exist.
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem.getFileStatus(RawLocalFileSystem.java:361)
        [junit] at org.apache.hadoop.fs.FileUtil.copy(FileUtil.java:192)
        [junit] at org.apache.hadoop.fs.FileUtil.copy(FileUtil.java:142)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem.rename(RawLocalFileSystem.java:253)
        [junit] at org.apache.hadoop.fs.ChecksumFileSystem.rename(ChecksumFileSystem.java:406)
        [junit] at org.apache.hadoop.fs.FilterFileSystem.rename(FilterFileSystem.java:138)
        [junit] at org.apache.hadoop.fs.ProxyFileSystem.rename(ProxyFileSystem.java:159)
        [junit] at org.apache.hadoop.fs.FilterFileSystem.rename(FilterFileSystem.java:138)
        [junit] at org.apache.hadoop.hive.ql.exec.FileSinkOperator$FSPaths.commit(FileSinkOperator.java:196)
        [junit] ... 11 more

        This is the first lower case letter that is processed, and all capital letters are processed.

        FWIW I noticed that Mac is not case sensitive for directory names, but Linux is, so this may be a clue

        Kevin Wilfong added a comment -

        I must have been mistaken about the date, I reverted to a revision before 4/11 and I still see the tests failing. Either that or there is something persistent causing the issue.

        Kevin Wilfong made changes -
        Field Original Value New Value
        Issue Type Bug [ 1 ] Test [ 6 ]
        Kevin Wilfong created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Kevin Wilfong
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development