Hive
  1. Hive
  2. HIVE-2923

testAclPositive in TestZooKeeperTokenStore failing in clean checkout when run on Mac

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OSX Lion

      Description

      When running testAclPositive in TestZooKeeperTokenStore in a clean checkout, it fails with the error:

      Failed to validate token path.

      org.apache.hadoop.hive.thrift.DelegationTokenStore$TokenStoreException: Failed to validate token path.
      at org.apache.hadoop.hive.thrift.ZooKeeperTokenStore.init(ZooKeeperTokenStore.java:207)
      at org.apache.hadoop.hive.thrift.ZooKeeperTokenStore.setConf(ZooKeeperTokenStore.java:225)
      at org.apache.hadoop.hive.thrift.TestZooKeeperTokenStore.testAclPositive(TestZooKeeperTokenStore.java:170)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at junit.framework.TestCase.runTest(TestCase.java:168)
      at junit.framework.TestCase.runBare(TestCase.java:134)
      at junit.framework.TestResult$1.protect(TestResult.java:110)
      at junit.framework.TestResult.runProtected(TestResult.java:128)
      at junit.framework.TestResult.run(TestResult.java:113)
      at junit.framework.TestCase.run(TestCase.java:124)
      at junit.framework.TestSuite.runTest(TestSuite.java:232)
      at junit.framework.TestSuite.run(TestSuite.java:227)
      at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:518)
      at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:1052)
      at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:906)
      Caused by: org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /zktokenstore-testAcl
      at org.apache.zookeeper.KeeperException.create(KeeperException.java:99)
      at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
      at org.apache.zookeeper.ZooKeeper.create(ZooKeeper.java:778)
      at org.apache.hadoop.hive.thrift.ZooKeeperTokenStore.ensurePath(ZooKeeperTokenStore.java:119)
      at org.apache.hadoop.hive.thrift.ZooKeeperTokenStore.init(ZooKeeperTokenStore.java:204)
      ... 17 more

      This message is also printed to standard out:
      Unable to load realm mapping info from SCDynamicStore

      The test seems to run fine in Linux, but more than one developer has reported this on a Mac.

      1. HIVE-2923.patch
        6 kB
        Thomas Weise

        Activity

        Kevin Wilfong created issue -
        Thomas Weise made changes -
        Field Original Value New Value
        Assignee Ashutosh Chauhan [ ashutoshc ] Thomas Weise [ thw ]
        Thomas Weise added a comment -

        The problem is that the ZooKeeper client is used before it is connected (may or may not occur depending on environment). I could reproduce this yesterday on my Mac but not this morning.

        Attached patch will add a wait for SyncConnected with timeout to address this. Can you please try the patch?

        Thomas Weise made changes -
        Attachment HIVE-2923.patch [ 12521531 ]
        Thomas Weise made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Affects Version/s 0.9.0 [ 12317742 ]
        Fix Version/s 0.9.0 [ 12317742 ]
        Thomas Weise added a comment -

        Updated patch to increase timeout for slow test environments.

        Thomas Weise made changes -
        Attachment HIVE-2923.patch [ 12521602 ]
        Thomas Weise made changes -
        Attachment HIVE-2923.patch [ 12521531 ]
        Ashutosh Chauhan added a comment -

        I was able to reproduce failures before the patch. With the latest patch, failures went away and tests pass. Patch looks good to me. Those who were seeing failures earlier can try with this patch and report back.

        Ashutosh Chauhan added a comment -

        Thanks, Thomas for taking this up. Very much appreciated!

        Ashutosh Chauhan added a comment -

        Committed to trunk. Thanks, Thomas!

        Ashutosh Chauhan made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hive-trunk-h0.21 #1358 (See https://builds.apache.org/job/Hive-trunk-h0.21/1358/)
        HIVE-2923 : testAclPositive in TestZooKeeperTokenStore failing in clean checkout when run on Mac (Thomas Weise via Ashutosh Chauhan) (Revision 1310406)

        Result = SUCCESS
        hashutosh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310406
        Files :

        • /hive/trunk/shims/src/common-secure/java/org/apache/hadoop/hive/thrift/HadoopThriftAuthBridge20S.java
        • /hive/trunk/shims/src/common-secure/java/org/apache/hadoop/hive/thrift/ZooKeeperTokenStore.java
        • /hive/trunk/shims/src/test/org/apache/hadoop/hive/thrift/TestZooKeeperTokenStore.java
        Kevin Wilfong added a comment -

        Thanks Thomas, that fixed the issue.

        Ashutosh Chauhan added a comment -

        This issue is closed now. It was released with the fix in 0.9.0. If there is a problem, please open a new jira and link this one with that.

        Ashutosh Chauhan made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in Hive-trunk-hadoop2 #54 (See https://builds.apache.org/job/Hive-trunk-hadoop2/54/)
        HIVE-2923 : testAclPositive in TestZooKeeperTokenStore failing in clean checkout when run on Mac (Thomas Weise via Ashutosh Chauhan) (Revision 1310406)

        Result = ABORTED
        hashutosh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1310406
        Files :

        • /hive/trunk/shims/src/common-secure/java/org/apache/hadoop/hive/thrift/HadoopThriftAuthBridge20S.java
        • /hive/trunk/shims/src/common-secure/java/org/apache/hadoop/hive/thrift/ZooKeeperTokenStore.java
        • /hive/trunk/shims/src/test/org/apache/hadoop/hive/thrift/TestZooKeeperTokenStore.java
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        2d 16h 7m 1 Thomas Weise 05/Apr/12 16:47
        Patch Available Patch Available Resolved Resolved
        22h 57m 1 Ashutosh Chauhan 06/Apr/12 15:44
        Resolved Resolved Closed Closed
        24d 5h 26m 1 Ashutosh Chauhan 30/Apr/12 21:11

          People

          • Assignee:
            Thomas Weise
            Reporter:
            Kevin Wilfong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development