Hive
  1. Hive
  2. HIVE-2906

Support providing some table properties by user via SQL

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.12.0
    • Component/s: Query Processor
    • Labels:
      None

      Description

      Some properties are needed to be provided to StorageHandler by user in runtime. It might be an address for remote resource or retry count for access or maximum version count(for hbase), etc.

      For example,

      select emp.empno, emp.ename from hbase_emp ('max.version'='3') emp;
      
      1. HIVE-2906.D2499.7.patch
        41 kB
        Phabricator
      2. HIVE-2906.D2499.6.patch
        39 kB
        Phabricator
      3. ASF.LICENSE.NOT.GRANTED--HIVE-2906.D2499.5.patch
        53 kB
        Phabricator
      4. ASF.LICENSE.NOT.GRANTED--HIVE-2906.D2499.4.patch
        53 kB
        Phabricator
      5. ASF.LICENSE.NOT.GRANTED--HIVE-2906.D2499.3.patch
        50 kB
        Phabricator
      6. ASF.LICENSE.NOT.GRANTED--HIVE-2906.D2499.2.patch
        49 kB
        Phabricator
      7. ASF.LICENSE.NOT.GRANTED--HIVE-2906.D2499.1.patch
        35 kB
        Phabricator

        Issue Links

          Activity

          Phabricator added a comment -

          navis requested code review of "HIVE-2906 [jira] Support providing some table properties by user via SQL".
          Reviewers: JIRA

          DPAL-1010 Support providing some table properties by user via SQL

          Some properties are needed to be provided to StorageHandler by user in runtime. It might be an address for remote resource or retry count for access or maximum version count(for hbase), etc.

          For example,

          select emp.empno, emp.ename from hbase_emp ('max.version'='3') emp;

          TEST PLAN
          EMPTY

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          AFFECTED FILES
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          MANAGE HERALD DIFFERENTIAL RULES
          https://reviews.facebook.net/herald/view/differential/

          WHY DID I GET THIS EMAIL?
          https://reviews.facebook.net/herald/transcript/5589/

          Tip: use the X-Herald-Rules header to filter Herald messages in your client.

          Navis added a comment -

          Passed all tests.

          Phabricator added a comment -

          njain has commented on the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".

          Can you add a test where the value is actually being used ?

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          Phabricator added a comment -

          navis has commented on the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".

          It was intended for specifying 'max version' for hbase handler and it seemed require some modifications. So I was thinking it could be done in a separated issue after this. But if it's OK, I'll work on that in this issue, too.

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".
          Reviewers: JIRA

          1. Added 'hbase.max.versions' as a example of using table properties
          2. Added test case 'hbase_max_versions.q'

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          AFFECTED FILES
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDe.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseStorageHandler.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HiveHBaseTableInputFormat.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/ResultWrapper.java
          hbase-handler/src/test/queries/hbase_max_versions.q
          hbase-handler/src/test/results/hbase_max_versions.q.out
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".
          Reviewers: JIRA

          1. Fixed test case to have deterministic result

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          AFFECTED FILES
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDe.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseStorageHandler.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HiveHBaseTableInputFormat.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/ResultWrapper.java
          hbase-handler/src/test/queries/hbase_max_versions.q
          hbase-handler/src/test/results/hbase_max_versions.q.out
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".
          Reviewers: JIRA

          1. Fixed not applying table properties to fetch operator
          2. Added 'hbase.versions.order' option for ordering of multi-versioned result
          3. Removed debug message, added test case

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          AFFECTED FILES
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDe.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseStorageHandler.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HiveHBaseTableInputFormat.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/ResultWrapper.java
          hbase-handler/src/test/queries/hbase_max_versions.q
          hbase-handler/src/test/results/hbase_max_versions.q.out
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".
          Reviewers: JIRA

          1. Fixed NPE
          2. Passed all tests

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          AFFECTED FILES
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDe.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseStorageHandler.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/HiveHBaseTableInputFormat.java
          hbase-handler/src/java/org/apache/hadoop/hive/hbase/ResultWrapper.java
          hbase-handler/src/test/queries/hbase_max_versions.q
          hbase-handler/src/test/results/hbase_max_versions.q.out
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          patrick o'leary added a comment -

          Are there any plans on incorporating this patch? Or is there an alternative

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".

          Rebase to trunk
          Removed HBase version property from patch (will make an another issue)

          Reviewers: JIRA

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          CHANGE SINCE LAST DIFF
          https://reviews.facebook.net/D2499?vs=8193&id=35901#toc

          AFFECTED FILES
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/FromClauseParser.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/MapReduceCompiler.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientpositive/serde_user_properties.q.out

          To: JIRA, navis
          Cc: njain

          Navis added a comment -

          This patch was very useful for implementing custom storage handler which needs runtime configurations.

          Hive QA added a comment -

          Overall: -1 build exited with an error

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12593110/HIVE-2906.D2499.6.patch

          ERROR: -1 due to 4 failed/errored test(s)
          Failed tests:
          org.apache.hadoop.hive.ql.parse.TestParseNegative.testParseNegative_missing_overwrite
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ptf_negative_DistributeByOrderBy
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_ptf_negative_PartitionBySortBy
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_input4

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/91/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/91/console

          Messages:
          Executing org.apache.hive.ptest.execution.CleanupPhase
          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests failed with: TestsFailedException: 4 tests failed

          This message is automatically generated.

          Brock Noland added a comment -

          Cancelling patch as it looks like the grammar changes cause some issues. I looked at TestNegativeParse missing_overwrite for example.

          Phabricator added a comment -

          navis updated the revision "HIVE-2906 [jira] Support providing some table properties by user via SQL".

          Fixed test cases

          Reviewers: JIRA

          REVISION DETAIL
          https://reviews.facebook.net/D2499

          CHANGE SINCE LAST DIFF
          https://reviews.facebook.net/D2499?vs=35901&id=35985#toc

          AFFECTED FILES
          ql/src/java/org/apache/hadoop/hive/ql/optimizer/GenMapRedUtils.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/FromClauseParser.g
          ql/src/java/org/apache/hadoop/hive/ql/parse/MapReduceCompiler.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/ParseContext.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/QB.java
          ql/src/java/org/apache/hadoop/hive/ql/parse/SemanticAnalyzer.java
          ql/src/test/queries/clientpositive/serde_user_properties.q
          ql/src/test/results/clientnegative/ptf_negative_DistributeByOrderBy.q.out
          ql/src/test/results/clientnegative/ptf_negative_PartitionBySortBy.q.out
          ql/src/test/results/clientpositive/serde_user_properties.q.out
          ql/src/test/results/compiler/errors/missing_overwrite.q.out

          To: JIRA, navis
          Cc: njain

          Edward Capriolo added a comment -

          +1. I think this is a very clean way to handle this. This opens up a lot of different ways to use input formats and serde

          Edward Capriolo added a comment -

          Committed. Thanks Navis.

          Ashutosh Chauhan added a comment -

          This issue has been fixed and released as part of 0.12 release. If you find further issues, please create a new jira and link it to this one.


            People

            • Assignee:
              Navis
              Reporter:
              Navis
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development