Hive
  1. Hive
  2. HIVE-2783

Predicate Pushdown failure a view with union when using MapReduce2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      ppd_union_view failure:

      [junit] Begin query: ppd_union_view.q
      [junit] 12/01/23 16:57:30 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:57:30 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:57:37 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:57:37 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:57:44 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:57:44 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:57:51 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:57:51 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:57:57 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:57:57 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:04 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:04 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:11 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:11 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:16 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:16 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:21 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:21 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:26 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:26 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:31 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:31 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:35 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:35 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:41 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:41 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:46 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:46 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:50 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:50 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:58:55 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:58:55 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:59:00 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:59:00 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] 12/01/23 16:59:04 WARN conf.Configuration: mapred.system.dir is deprecated. Instead, use mapreduce.jobtracker.system.dir
      [junit] 12/01/23 16:59:04 WARN conf.Configuration: mapred.local.dir is deprecated. Instead, use mapreduce.cluster.local.dir
      [junit] diff -a -I file: -I pfile: -I hdfs: -I /tmp/ -I invalidscheme: -I lastUpdateTime -I lastAccessTime -I [Oo]wner -I CreateTime -I LastAccessTime -I Location -I LOCATION ' -I transient_lastDdlTime -I last_modified_ -I java.lang.RuntimeException -I at org -I at sun -I at java -I at junit -I Caused by: -I LOCK_QUERYID: -I LOCK_TIME: -I grantTime -I [.][.][.] [0-9]* more -I job_[0-9]_[0-9] -I USING 'java -cp /home/cloudera/Code/hive/build/ql/test/logs/clientpositive/ppd_union_view.q.out /home/cloudera/Code/hive/ql/src/test/results/clientpositive/ppd_union_view.q.out
      [junit] 565c565
      [junit] < NULL NULL NULL
      [junit]
      [junit] > key3 value3 2011-10-13
      [junit] 588c588
      [junit] < NULL NULL NULL
      [junit]
      [junit] > key4 value4 2011-10-14
      [junit] Exception: Client execution results failed with error code = 1
      [junit] See build/ql/tmp/hive.log, or try "ant test ... -Dtest.silent=false" to get more logs.
      [junit] junit.framework.AssertionFailedError: Client execution results failed with error code = 1
      [junit] See build/ql/tmp/hive.log, or try "ant test ... -Dtest.silent=false" to get more logs.
      [junit] at junit.framework.Assert.fail(Assert.java:50)
      [junit] at org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_ppd_union_view(TestCliDriver.java:179)
      [junit] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [junit] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      [junit] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      [junit] at java.lang.reflect.Method.invoke(Method.java:616)
      [junit] at junit.framework.TestCase.runTest(TestCase.java:168)
      [junit] at junit.framework.TestCase.runBare(TestCase.java:134)
      [junit] at junit.framework.TestResult$1.protect(TestResult.java:110)
      [junit] at junit.framework.TestResult.runProtected(TestResult.java:128)
      [junit] at junit.framework.TestResult.run(TestResult.java:113)
      [junit] at junit.framework.TestCase.run(TestCase.java:124)
      [junit] at junit.framework.TestSuite.runTest(TestSuite.java:243)
      [junit] at junit.framework.TestSuite.run(TestSuite.java:238)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:420)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:911)
      [junit] at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:768)
      [junit] See build/ql/tmp/hive.log, or try "ant test ... -Dtest.silent=false" to get more logs.)

        Activity

        Zhenxiao Luo added a comment -

        Fixed in MAPREDUCE-3952


          People

          • Assignee:
            Zhenxiao Luo
            Reporter:
            Zhenxiao Luo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development