Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-27299

Upgrade guava version to 31.1-jre to fix CVE

    XMLWordPrintableJSON

Details

    Description

      The guava version in Hive master branch is 22.0 which has 2 Direct CVE:

      1. CVE-2020-8908
      2. CVE-2018-10237

      Component like Tez 0.10.2 (used in hive) has also moved to 31.1-jre.

      Attachments

        Issue Links

          Activity

            People

              Aggarwal_Raghav Raghav Aggarwal
              Aggarwal_Raghav Raghav Aggarwal
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1h 10m
                  1h 10m