Hive
  1. Hive
  2. HIVE-2719

Fix test failures caused by HIVE-2589

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      149 new test failures appeared on Hudson after HIVE-2589 and HIVE-2682 were committed:

      https://builds.apache.org/job/Hive-trunk-h0.21/1195/

      @Ashutosh: Can you please take a look?

        Activity

        Ashutosh Chauhan added a comment -

        Sure. I ran few those tests failed on jenkins on my local machines and all of them passed. Looks like either some environment issue or non-determinism in test cases. Will keep digging.

        Carl Steinbach added a comment -

        I created a copy of the Hudson build job here:
        https://builds.apache.org/job/Hive-trunk-h0.21-dbg/

        The first and second builds failed with the same errors as the original
        job, which I think rules out the possibility of a dirty build workspace.

        I have also triggered three more jobs in the hope of determining which
        checkin triggered the test failures:

        job #3: HIVE-2682 trunk@1230379
        job #4: HIVE-2589 trunk@1230390
        job #5: HIVE-2705 trunk@1230091 (checkin from immediately before symptoms appeared)

        Carl Steinbach added a comment -

        Looks like the test failures are tied to HIVE-2589:
        https://builds.apache.org/job/Hive-trunk-h0.21-dbg/4/

        @Ashutosh: Do you think you can have a fix for this ready in the next couple of days? If not, I think we should consider temporarily backing this patch out.

        Carl Steinbach added a comment -

        I was also able to reproduce the test failures on our internal Jenkins server, so this is not something unique to Apache Hudson.

        He Yongqiang added a comment -

        I am planning to revert changes that cause the current test failures. And we can get them back together with their fixes. What do u think?

        It seems some of these commits that cause test failures:

        r1230774 | namit | 2012-01-12 12:43:56 -0800 (Thu, 12 Jan 2012) | 4 lines
        HIVE-2504 Warehouse table subdirectories should inherit the group permissions of the warehouse
        parent directory (Chinna Rao Lalam via namit)
        ------------------------------------------------------------------------
        r1230758 | namit | 2012-01-12 12:26:20 -0800 (Thu, 12 Jan 2012) | 3 lines
        HIVE-2695 Add PRINTF() Udf (Zhenxiao Luo via namit)
        ------------------------------------------------------------------------
        r1230391 | amareshwari | 2012-01-11 20:11:37 -0800 (Wed, 11 Jan 2012) | 1 line
        HIVE-2629. Make a single Hive binary work with both 0.20.x and 0.23.0. (Thomas Weise via amareshwari)
        ------------------------------------------------------------------------
        r1230390 | hashutosh | 2012-01-11 19:59:06 -0800 (Wed, 11 Jan 2012) | 1 line
        HIVE-2589: Newly created partition should inherit properties from table (Ashutosh Chauhan)

        I think it is because r1230774(HIVE-2504) and r1230390(HIVE-2589). Any other ideas?

        Carl Steinbach added a comment -

        @Yongqiang: I think this proves that the diffs were introduced by HIVE-2589: https://builds.apache.org/job/Hive-trunk-h0.21-dbg/4/

        I'm +1 on backing stuff out to fix the tests.

        He Yongqiang added a comment -

        @Carl, i am trying to revert Hive-2589 locally to see if it can pass tests or not.
        At the same time, Carl, can u put a patch to revert it, or can you test/commit my revert? we would like to fix the test failures today.

        He Yongqiang added a comment -

        after reverting HIVE-2589, i am still getting these errors:

        [junit] Begin query: udtf_explode2.q
        [junit] java.lang.RuntimeException: Error while running command to get file permissions : org.apache.hadoop.util.Shell$ExitCodeException:
        [junit] at org.apache.hadoop.util.Shell.runCommand(Shell.java:195)
        [junit] at org.apache.hadoop.util.Shell.run(Shell.java:134)
        [junit] at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:286)
        [junit] at org.apache.hadoop.util.Shell.execCommand(Shell.java:354)
        [junit] at org.apache.hadoop.util.Shell.execCommand(Shell.java:337)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem.execCommand(RawLocalFileSystem.java:481)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem.access$100(RawLocalFileSystem.java:37)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem$RawLocalFileStatus.loadPermissionInfo(RawLocalFileSystem.java:407)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem$RawLocalFileStatus.getPermission(RawLocalFileSystem.java:382)
        [junit] at org.apache.hadoop.fs.ProxyFileSystem.swizzleFileStatus(ProxyFileSystem.java:56)
        [junit] at org.apache.hadoop.fs.ProxyFileSystem.listStatus(ProxyFileSystem.java:177)
        [junit] at org.apache.hadoop.fs.FilterFileSystem.listStatus(FilterFileSystem.java:153)
        [junit] at org.apache.hadoop.hive.ql.io.CombineHiveInputFormat.getSplits(CombineHiveInputFormat.java:323)
        [junit] at org.apache.hadoop.mapred.JobClient.writeOldSplits(JobClient.java:810)
        [junit] at org.apache.hadoop.mapred.JobClient.submitJobInternal(JobClient.java:781)
        [junit] at org.apache.hadoop.mapred.JobClient.submitJob(JobClient.java:730)
        [junit] at org.apache.hadoop.hive.ql.exec.ExecDriver.execute(ExecDriver.java:432)
        [junit] at org.apache.hadoop.hive.ql.exec.ExecDriver.main(ExecDriver.java:690)
        [junit] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        [junit] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        [junit] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        [junit] at java.lang.reflect.Method.invoke(Method.java:597)
        [junit] at org.apache.hadoop.util.RunJar.main(RunJar.java:156)
        [junit]
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem$RawLocalFileStatus.loadPermissionInfo(RawLocalFileSystem.java:432)
        [junit] at org.apache.hadoop.fs.RawLocalFileSystem$RawLocalFileStatus.getPermission(RawLocalFileSystem.java:382)
        [junit] at org.apache.hadoop.fs.ProxyFileSystem.swizzleFileStatus(ProxyFileSystem.java:56)
        [junit] at org.apache.hadoop.fs.ProxyFileSystem.listStatus(ProxyFileSystem.java:177)
        [junit] at org.apache.hadoop.fs.FilterFileSystem.listStatus(FilterFileSystem.java:153)
        [junit] at org.apache.hadoop.hive.ql.io.CombineHiveInputFormat.getSplits(CombineHiveInputFormat.java:323)
        [junit] at org.apache.hadoop.mapred.JobClient.writeOldSplits(JobClient.java:810)
        [junit] at org.apache.hadoop.mapred.JobClient.submitJobInternal(JobClient.java:781)
        [junit] at org.apache.hadoop.mapred.JobClient.submitJob(JobClient.java:730)
        [junit] at org.apache.hadoop.hive.ql.exec.ExecDriver.execute(ExecDriver.java:432)
        [junit] at org.apache.hadoop.hive.ql.exec.ExecDriver.main(ExecDriver.java:690)
        [junit] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        [junit] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        [junit] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        [junit] at java.lang.reflect.Method.invoke(Method.java:597)
        [junit] at org.apache.hadoop.util.RunJar.main(RunJar.java:156)

        Thomas Weise added a comment -

        I observed inconsistent results before r1230390. On the same machine I had a run where all tests passed and one where a few failed. The few that failed passed when running them separately.

        Carl Steinbach added a comment -

        @Yongqiang: I'd like to get this fixed too. I can test/commit your patch. I recommend we back out HIVE-2589 first since that's the cause of 149 of the failures, and then work back from there. Sound good?

        He Yongqiang added a comment -

        sure, let's get it fixed today. Thanks Carl!

        Phabricator added a comment -

        heyongqiang requested code review of "HIVE-2719 [jira] Fix test failures caused by HIVE-2589".
        Reviewers: JIRA

        https://issues.apache.org/jira/browse/HIVE-2719

        149 new test failures appeared on Hudson after HIVE-2589 and HIVE-2682 were committed:

        https://builds.apache.org/job/Hive-trunk-h0.21/1195/

        @Ashutosh: Can you please take a look?

        TEST PLAN
        EMPTY

        REVISION DETAIL
        https://reviews.facebook.net/D1281

        AFFECTED FILES
        metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
        common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
        ql/src/test/results/clientpositive/part_inherit_tbl_props.q.out
        ql/src/test/results/clientpositive/part_inherit_tbl_props_empty.q.out
        ql/src/test/results/clientpositive/part_inherit_tbl_props_with_star.q.out
        ql/src/test/queries/clientpositive/part_inherit_tbl_props_with_star.q
        ql/src/test/queries/clientpositive/part_inherit_tbl_props.q
        ql/src/test/queries/clientpositive/part_inherit_tbl_props_empty.q

        MANAGE HERALD DIFFERENTIAL RULES
        https://reviews.facebook.net/herald/view/differential/

        WHY DID I GET THIS EMAIL?
        https://reviews.facebook.net/herald/transcript/2685/

        Tip: use the X-Herald-Rules header to filter Herald messages in your client.

        Phabricator added a comment -

        cwsteinbach has accepted the revision "HIVE-2719 [jira] Fix test failures caused by HIVE-2589".

        REVISION DETAIL
        https://reviews.facebook.net/D1281

        Carl Steinbach added a comment -

        @Yongqiang: I'm running the tests now.

        Ashutosh Chauhan added a comment -

        Looks like HIVE-2589 was not the cause of failure. Last hudson builds only had 2 failures https://builds.apache.org/job/Hive-trunk-h0.21-dbg/lastBuild/ which were same as before that commit. Before reverting, lets make sure 2589 indeed is the cause.

        Ashutosh Chauhan added a comment -
        Ashutosh Chauhan added a comment -

        Even https://builds.apache.org/job/Hive-trunk-h0.21-dbg/3/ which includes 2589 only had 2 failures.

        He Yongqiang added a comment -

        I just finished a full test run against revision 1230379, and all tests passed.

        Carl Steinbach added a comment -

        @Ashutosh: Build #3 was against revision 1230379, which actually corresponds to HIVE-2682. Build #4 corresponds to revision 1230390 (HIVE-2589), and this build fails with +149 errors compared to build #3. Build #5 corresponds to revision 1230091 (HIVE-2705) and has two failures. I believe Jenkins is confused about the "changes" because I wasn't running through the revisions in order.

        Here's the logical order of the builds:

        HIVE-2705 r1230091 https://builds.apache.org/job/Hive-trunk-h0.21-dbg/5/ 2 Failures
        HIVE-2682 r1230379 https://builds.apache.org/job/Hive-trunk-h0.21-dbg/3/ 2 Failures
        HIVE-2589 r1230390 https://builds.apache.org/job/Hive-trunk-h0.21-dbg/4/ 151 Failures

        He Yongqiang added a comment -

        @Carl, how is the test running?

        Carl Steinbach added a comment -

        Tests are still running, but I see that TestCliDriver.ppr_pushdown2 failed with a timeout. I'm going to restart the job on a faster Hudson slave and hope that it finishes in the next 3 hours.

        Carl Steinbach added a comment -

        Committed to trunk. Thanks Yongqiang!

        Hudson added a comment -

        Integrated in Hive-trunk-h0.21 #1204 (See https://builds.apache.org/job/Hive-trunk-h0.21/1204/)
        HIVE-2719. Revert HIVE-2589 (He Yongqiang via cws)

        cws : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1232766
        Files :

        • /hive/trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
        • /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props.q
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props_empty.q
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props_with_star.q
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props.q.out
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props_empty.q.out
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props_with_star.q.out
        Ashutosh Chauhan added a comment -

        This issue is closed now. It was released with the fix in 0.9.0. If there is a problem, please open a new jira and link this one with that.

        Hudson added a comment -

        Integrated in Hive-trunk-hadoop2 #54 (See https://builds.apache.org/job/Hive-trunk-hadoop2/54/)
        HIVE-2719. Revert HIVE-2589 (He Yongqiang via cws) (Revision 1232766)

        Result = ABORTED
        cws : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1232766
        Files :

        • /hive/trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
        • /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props.q
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props_empty.q
        • /hive/trunk/ql/src/test/queries/clientpositive/part_inherit_tbl_props_with_star.q
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props.q.out
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props_empty.q.out
        • /hive/trunk/ql/src/test/results/clientpositive/part_inherit_tbl_props_with_star.q.out

          People

          • Assignee:
            He Yongqiang
            Reporter:
            Carl Steinbach
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development